2

Following this tutorial exactly: https://learn.adafruit.com/adafruits-raspberry-pi-lesson-5-using-a-console-cable/overview

i.e.:

  • Drivers are installed
  • UART line is added and enabled

I get a blank screen when trying to access the serial terminal using MacOS and Linux. I can boot the Pi0 and see that everything is working when hooking it up to a display.

Using CoolTerm, the application just freezes up.

Has anyone else had this problem?

  • 1
    If you followed the tutorial exactly it either works, the tutorial is wrong, or you didn't follow exactly - unless you tell us what YOU did no one can help. – Milliways Apr 23 '18 at 23:57
  • I DID exactly what the tutorial asked. The other possibility is there there is/are assumption(s) not stated in the tutorial or anywhere else as far as I can tell. For instance, maybe the tutorial only works for certain versions of Raspbian (or default configuration has certain parameters disabled somewhere), maybe I’ve run into a bug, etc... – Sterling Butters Apr 24 '18 at 0:01
  • 1
    My question stemmed from here: raspberrypi.stackexchange.com/questions/82911/… – Sterling Butters Apr 24 '18 at 0:03
  • But since that ^ seemed like a dead end, I wanted to make the question more general and elaborate that it doesn’t seem to matter what the host (USB-end) is, I get the same result. Also I can see Raspbian boot now that I have a miniHDMI to HMDI adapter – Sterling Butters Apr 24 '18 at 0:32
  • Did you try connecting your rx and tx lines and typing in your keyboard? That will make sure the cable works. Also check the baud rate, make sure you specify the baud rate in the coolterm settings. The guide you linked says 115200 – Hunter Akins Apr 24 '18 at 18:12
1

Assuming you have a Pi Zero (not the Pi Zero Wireless), your UART should be acessible as /dev/ttyAMA0 or /dev/serial0. You should check whether the UART hardware is working and whether a login process is initiated on it.

To check the hardware:

  • Disable the Linux UART console using raspi-config or by editing the config files manually
  • Reboot
  • Short TX and RX pins with a wire
  • Run a terminal on your RPi with that UART, e.g. minicom -D /dev/serial0 or screen /dev/serial0
  • Type something: you should see whatever you type due to RX/TX loopback

To see the login process:

  • Enable the Linux UART console using raspi-config or by editing the config files manually
  • Reboot
  • Try runin a terminal on your RPi with that UART, you should see a "Device busy" error.
  • Run ps -t /dev/serial0 /dev/ttyAMA0 on your RPi as root. You should see a process attached to one of these devices.
  • Sorry for the late response - its been a nightmare to get my Pi0 connected to the internet to install screen. While console is disabled I just get a blinking cursor with nothing echoed to screen. Any ideas? – Sterling Butters May 13 '18 at 19:08
  • @SterlingButters Assuming you're trying to check the hardware with a loopback wire, that would mean you either use wrong pins or your pins are damaged. It's practically impossible to configure a UART wrong in loopback configuration. – Dmitry Grigoryev May 14 '18 at 6:53
  • Hmmm I did solder the GPIO header myself but I figured since I was getting power to the RPi0 everything else would be fine. It doesn’t matter what direction the header is installed right? – Sterling Butters May 14 '18 at 16:22
  • When I said about damaged pins, I didn't mean mechanical damage but rather electrical. Though it wouldn't hurt to check the soldering if you have any doubts. Of course, pin header can face either direction. – Dmitry Grigoryev May 15 '18 at 10:47
  • So using a different Pi0 I am able to get input echoed when "checking hardware" on /dev/serial0. However while "initiating login process" (if the RX & TX short is still in place) I get a hung boot sequence between a flashing gray screen with an ellipsis in the middle (all of which doesn't look very good). If I remove the short during boot and then reconnect afterward, I get cannot exec 'serial0': No such file directory - any ideas? – Sterling Butters May 15 '18 at 20:43

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.