0

Raspberry pi 3. Wifi was working fine, I didn't change anything, and suddenly it stopped working. The only difference I can see between my situation and others is that they're also not associated and not configured, so changing the /etc/network/interfaces file does the trick for them.

Here is my /etc/network/interfaces file

source-directory /etc/network/interfaces.d

auto lo
iface lo inet loopback

#auto eth0
iface eth0 inet manual

#auto wlan0
#iface wlan0 inet manual

allow-hotplug wlan0
iface wlan0 inet manual
    wpa-conf /etc/wpa_supplicant/wpa_supplicant.conf

allow-hotplug wlan1
iface wlan1 inet manual
    wpa-conf /etc/wpa_supplicant/wpa_supplicant.conf

#iface default inet dhcp

My /etc/wpa_supplicant/wpa_supplicant.conf file

ctrl_interface=DIR=/var/run/wpa_supplicant GROUP=netdev
update_config=1
country=US

network={
    ssid="CalVisitor"
    key_mgmt=NONE
}

When I run $ ifconfig wlan0

wlan0: flags=4163<UP,BROADCAST,RUNNING,MULTICAST>  mtu 1500
    inet 10.105.204.61  netmask 255.255.255.252  broadcast 10.105.204.63
    inet6 2607:f140:6000:13:6b43:85ae:7cfc:b16a  prefixlen 64  scopeid 
0x0<global>
    inet6 fe80::1eba:ffa3:a464:a972  prefixlen 64  scopeid 0x20<link>
    ether b8:27:eb:19:39:9c  txqueuelen 1000  (Ethernet)
    RX packets 41830  bytes 2474840 (2.3 MiB)
    RX errors 0  dropped 574  overruns 0  frame 0
    TX packets 1631  bytes 140473 (137.1 KiB)
    TX errors 0  dropped 0 overruns 0  carrier 0  collisions 0

I think I'm supposed to have an inet addr?, and

it says "Link down" when I hover over the wifi icon. I don't know what that means or why it says that.

enter image description here

Here is ip link list

1: lo: <LOOPBACK,UP,LOWER_UP> mtu 65536 qdisc noqueue state UNKNOWN mode 
DEFAULT group default qlen 1
link/loopback 00:00:00:00:00:00 brd 00:00:00:00:00:00
2: enxb827eb4c6cc9: <NO-CARRIER,BROADCAST,MULTICAST,UP> mtu 1500 qdisc pfifo_fast state DOWN mode DEFAULT group default qlen 1000
link/ether b8:27:eb:4c:6c:c9 brd ff:ff:ff:ff:ff:ff
3: wlan0: <BROADCAST,MULTICAST,UP,LOWER_UP> mtu 1500 qdisc pfifo_fast state UP mode DORMANT group default qlen 1000
link/ether b8:27:eb:19:39:9c brd ff:ff:ff:ff:ff:ff

ip addr

link/loopback 00:00:00:00:00:00 brd 00:00:00:00:00:00
inet 127.0.0.1/8 scope host lo
   valid_lft forever preferred_lft forever
inet6 ::1/128 scope host 
   valid_lft forever preferred_lft forever
2: enxb827eb4c6cc9: <NO-CARRIER,BROADCAST,MULTICAST,UP> mtu 1500 qdisc pfifo_fast state DOWN group default qlen 1000
link/ether b8:27:eb:4c:6c:c9 brd ff:ff:ff:ff:ff:ff
3: wlan0: <BROADCAST,MULTICAST,UP,LOWER_UP> mtu 1500 qdisc pfifo_fast state UP group default qlen 1000
link/ether b8:27:eb:19:39:9c brd ff:ff:ff:ff:ff:ff
inet 10.105.204.61/30 brd 10.105.204.63 scope global wlan0
   valid_lft forever preferred_lft forever
inet6 2607:f140:6000:13:6b43:85ae:7cfc:b16a/64 scope global mngtmpaddr noprefixroute dynamic 
   valid_lft 2592000sec preferred_lft 604800sec
inet6 fe80::1eba:ffa3:a464:a972/64 scope link 
   valid_lft forever preferred_lft forever
  • 2
    "The only difference I can see between my situation and others" is that they ASK QUESTIONS and PROVIDE SOME DATA. – Milliways Apr 26 '18 at 6:30
  • Do you mean you have a problem with the name of your interface? check this – Kreumz Apr 26 '18 at 7:24
  • I think I'm supposed to have an inet addr? -> Maybe some previous version of the tool did that (note that ifconfig is depreciated anyway in favour of ip link and ip addr). Anyway, you have an address there, 10.105.204.61, and some RX/TX transfers have occurred. I presume ping google.com etc. does not work though. – goldilocks Apr 26 '18 at 17:07
  • I added ip link list and ip addr above. ping google.com gave me ping: google.com: Temporary failure in name resolution – Kevin Corcoran Apr 26 '18 at 17:17
  • I also tried ln -s /dev/null /etc/udev/rules.d/80-net-slot.rules but got ln: failed to create symbolic link '/etc/udev/rules.d/80-net-slot.rules': File exists. So then I ran it with sudo and reboot the pi but I'm still not connect to the internet. – Kevin Corcoran Apr 26 '18 at 17:21
0

You have not specified OS, and the information posted is incomplete; however some things are clear.

enxb827eb4c6cc9 indicates Stretch which introduced Predictable Network Interface Names (even if disabled 3 weeks later).

The /etc/network/interfaces file appears to be a modified Jessie (or possibly Wheezy) file which is incompatible with the dhcpcd configuration on Stretch.

(The first rule is to ALWAYS make a copy of configuration files BEFORE modifying them.)

How to set up networking/WiFi explains Raspbian networking, and lists the default settings of the configuration files. Restoring these should make it work (if there are no other incompatible changes).

Your Answer

By clicking "Post Your Answer", you acknowledge that you have read our updated terms of service, privacy policy and cookie policy, and that your continued use of the website is subject to these policies.

Not the answer you're looking for? Browse other questions tagged or ask your own question.