0

I am going on a limp right now and I'm going to ask the following.

Given that the ssh is disabled and that I'm using a Windows 8 machine with putty installed, I would like to know the easiest way to enable ssh and connect to my Raspberry Pi Zero W with installed Rapspbian Stretch (2018 edition).

Before someone says that there are tutorials I have already tried two (this one and this one) that have worked in the past for me but now I keep getting an error message from Putty that says

Unable to open connection to raspberrypi.local

Host does not exist

So, can you suggest to me a solution?

5
  • assuming you can ping the address of the pi thought?
    – Chad G
    Apr 26, 2018 at 18:43
  • Because there is no speech coloring I think the answer to your question is "yes, I can ping the address of my raspberry pi".
    – Ka_Papa
    Apr 26, 2018 at 18:50
  • @jsotola I corrected it. I meant to say that they worked in the past that they don't work anymore because I keep getting an error message.
    – Ka_Papa
    Apr 26, 2018 at 19:07
  • 1
    Host does not exist is pretty definitive. Either the Windows box isn't getting a DNS translation for that or else it is the wrong IP (possibly from being cached somewhere). You need to port scan your LAN looking for something with 22 open.
    – goldilocks
    Apr 26, 2018 at 19:31
  • For those who don't have a correct driver in the first place it has been linked here on a separate forum. Forum: factoryforward.com/… Driver: factoryforward.com/wp-content/uploads/2018/01/mod-duo-rndis.zip
    – James m
    Jul 15, 2021 at 21:34

4 Answers 4

1
Unable to open connection to raspberrypi.local

Host does not exist

Means the host PC cannot find a connection at the translated IP address from raspberrypi.local. It can result from a number of core issues.

The Pi does not have SSH enabled. If you have followed the tutorials and there have been no errors, then this seems to have been enabled.

The Pi has changed IP address and the PC has not noticed. You can plug the Pi into a monitor and check the IP address currently assigned.

sudo ifconfig -a

You can check your Wifi Router to see what IP address has been assigned(look for DHCP and routing tables). You can use a network scanner to locate the Pi(Google nmap).

The Pi and the PC are on different networks or subnets, meaning the addresses on the two devices can not see each other.

The Pi/PC is not on the Wifi network.

Number one troubleshooting step for this type of thing is reboot both devices.

If you are still having issues open the Windows command prompt and type

ping raspberrypi.local

this will tell you the number of network packets that successfully get to the Pi and the IP address that raspberrypi.local represents to the Windows machine.

Then run

ipconfig

this will list all the network devices on the PC and tell you their IP addresses.

come back and lets us know the values and we may be able to troubleshoot further.

1
  • Here is why that troubleshoot is wrong. First and foremost even if the ssh is enabled there is a pre-process that need to be completed before everything else and that is editing cmdline.txt and config.txt. Now the main reason that I did all this is because I didn't have a spare monitor and a mini-HDMI laying around so ifconfig would be useless .Now, let's ignore all that and suppose that my raspberry pi is connected to my PC and I can ping it, in that case ipconfig would be useless because, in theory, I would be able to connect using Putty.
    – Ka_Papa
    May 1, 2018 at 17:25
1

For anyone new that reads this post I followed this video tutorial.

The step-by-step process for someone that wants to take remote access from a Raspberry Pi Zero W using Windows and Putty is the following:

1) Download and install the latest Raspbian using Etcher

2) Create empty ssh file (that means ssh and not ssh.txt because that would be text)

3) Open config.txt with wordpad or notepad++ and write dtoverlay=dwc2 at the very bottom of the file.

4) Open cmdline.txt with wordpad or notepad++ and after the word rootwait press space and write modules-load=dwc2,g_ether.

5) Download and install Bonjour for windows and Putty

5.5) Connect your microusb with raspberry's data port

6) Open Putty and as HOST input [email protected]. After that input raspberry as the default password

7) Once you are logged in type sudo nano /etc/wpa_supplicant/wpa_supplicant.confand then paste the following lines your router's SSID and Password :

network={ ssid="NETWORK" psk="PASSWORD" }

8)Type sudo wpa_cli reconfigure to apply changes

9) Shutdown rapsberry pi or use ifconfig to re-connect using your raspberry pi's IP

Now you will be able to use raspberry pi remotely without having to connect it to your PC everytime

P.S My mistake is that the image wasn't installed correctly and that I had a typo in my password.

2
  • Another alternative is to use a serial connection over the GPIO pins. See thepihut.com/products/… Aug 26, 2019 at 11:43
  • I too have been following this tutorial and I'm encountering an error. After connecting the raspberry pi, Windows started setting up the device and it now says USB Serial Device (COM3). It is not showing in the Network Connections like it did in the tutorial. What can I do as my attempt to use Putty with HOST gives the error that it doesn't exist.
    – MRT
    May 23, 2021 at 11:34
0

Mine was working fine for a while, then i wanted to test my GPS module for which i had to change two boot files cmdline.txt and config.txt. This was when my connection failed for the first time. Then i reinstalled the OS on my sd card which didnt fix the issue as well. Would love some help ! Thanks

0

I was having the same problem. I followed this tutorial: https://www.youtube.com/watch?v=F5OYpPUJiOw&t=228s&ab_channel=CapTrongNam-HowTo but it wasn't working. the raspberry was not even visible! (to check this, just use the arp -a command). So I connected my raspberry via ethernet to the modem, and soon it was available to connect. I opened the putty and entered successfully. The error was that rfkill was blocking access via wifi because I needed to set the country code first.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.

Not the answer you're looking for? Browse other questions tagged or ask your own question.