2

I'm a total n00b when it comes to Raspberry Pi; I bought one yesterday and installed Raspbmc.

Everything is working quite well except for wifi. It's an old dongle using the Ralink 2571 chipset. I got it to an almost working state, but I'm missing the final step.

The dongle sees the networks immediately. I changed the settings through NetworkManager to use a static IP. I then ssh through the wired IP, and turn off the power saving mode (iw wlan0 set power_save off), unplug the wired network, and I get a pretty stable connection through wifi.

However, I haven't been able to make this change permanent. I've put wireless-power off in /etc/network/interfaces but it does nothing. I've changed /usr/lib/pm-utils/power.d/wireless to always set pm to "off", but it also does nothing. Then there's settings.xml for the NetworkManager add on, but I don't see any option to set power management there.

Short of putting some in a startup script, what can I do? For the startup script option, what would be the correct startup script?

Thanks in advance!

2

Solved. I put the command in a script in /etc/pm/power.d which solved the problem.

1

in /etc/network/interfaces, add this line after wlan0

post-up iw wlan0 set power_save off

Then reboot and see if the power_save status has been set properly

  • 1
    Thanks for the suggestion! Unfortunately, that didn't work. – ggambett Jul 10 '13 at 15:27
1

As root I made an executable script in /etc/network/if-up.d named powersaveoff:

#!/bin/sh

# The connection is dropped when powersave if turned on.
# So we disable it.

# Check if the current interface is wlan0 otherwise exit.
[ "$IFACE" = "wlan0" ] || exit 0

# Disable the powersave
iw wlan0 set power_save off

Don't forget to chmod 755 the script. After a reboot the power_save function is off. You can check it with:

sudo iw dev wlan0 get power_save

It should return:

Power save: off

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.