1

I recently got my first Raspberry Pi (model 3 B+) plus a starter kit from Adafruit, and I have encountered my first challenge: boot the darn thing. The starter kit came with a micro SD with NOOBs installed, and without a way to check I will assume that it is current.

Problem: The power LED is blinking (solid 2sec, four 1Hz blinks, four 2Hz blinks, repeat), and the HDMI monitor shows the rainbow screen and a yellow lightning bolt in the upper right. I've looked into the "blinking power LED" issue and concluded that this is bad (yes, I've tried a different USB cable with the same effect). The ACT LED does nothing.

But beyond that, is there a specific meaning to the blinking power LED? That is, is the blinking pattern that I noticed significant or does it simply indicate "bad"?

  • 2
    The power LED DOES NOT BLINK. It should be solidly illuminated unless the voltage is low. (The Pi3B+ has the LED controlled by software, rather than directly by hardware as in earlier models, so it is POSSIBLE, but unlikely). – Milliways Apr 29 '18 at 3:35
  • 2
    See raspberrypi.stackexchange.com/questions/81458/… If you look at the SD Card in a PC, check if it contains a file bcm2710-rpi-3-b-plus.dtb which would indicate support for Pi3B+ (at least on Raspbian not sure about NOOBS). – Milliways Apr 29 '18 at 3:57
  • 1
    It's the LED labeled PWR that's blinking, and it is consistently doing so in a pattern, so apparently it's possible. Don't know if it means anything specific though other than "bad". Can't check the SD card in PC right now. I'll get back to you once I get something that can read micro SDs. – John Cox Apr 29 '18 at 4:08
1

The Boot Problems Sticky mentions the problem you described.

If you have one of the latest PI 3B+ which won't boot and it keeps stuck on the rainbow screen, while also displaying the under voltage (lightening bolt) icon, and/or the red LED flashing then you are simply are using boot code that is too old. Please download the very latest version of Raspbian, or do an upgrade to it.

Apparently this is because the intended diagnostic is being sent to the wrong pin.

This is not an intended diagnostic but a side effect caused because the Pi3B+ voltage detector is part of the regulator chip with no external pin. It needs to be read from a register which requires matching firmware.

1

I thing it could be 2 problems described here: Raspberry Pi with boots up with Rainbow screen and here: What does the lightning bolt mean?

The second one also could explain blinking power LED. Remember that Rapsberry Pi require quite high current power supply about 2A or so on. In typical power supply, when your device try to drain to much current, the voltage is dropping.

In first place I will try to solve the problem with power. After that deal with boot problem.

  • It turned out to be just an OS version error. I have nothing hooked up to this Pi except the HDMI output, so I figured that if that was drawing too much power, then something was wrong. Turned out to be a versioning error, though I don't know why that caused the lighting bolt. There was certainly no overdraw with only the HDMI connected. – John Cox May 8 '18 at 0:34
0

If the red PWR LED is flashing, it indicates that voltage from your power supply drops below 4.63V. Seems there is a problem with your power supply or an overload by attached peripherals, e.g. USB-devices without its own power supply. Look at What do system LEDs signify? for further information.

As @Milliways wrote in his comment this may not work if you use the wrong firmware. To ensure your firmware is up to date you should test your RPi 3B+ with the latest official Raspbian Stretch Lite.

  • This may have been true for the Pi3B but NOT the Pi3B+ The voltage detector is part of the regulator chip with no external pin. It needs to be read from a register - who knows what it will do without matching firmware. – Milliways Apr 29 '18 at 22:46
  • Nope, wasn't that. It was just that the Pi3B+ is so new to Adafruit (where I bought it) that not all of their SD cards have been updated to the latest image, which includes bcm2710-rpi-3-b-plus.dtb. When I asked this question, that file wasn't there. Moving on to next problem: "Error resizing existing FAT partition" – John Cox May 8 '18 at 0:33
0

Not sure if the question has been answered yet but...

Short Answer: Try reformatting the SD Card with a different OS or which SDs

Long Anser: The code (4 short blinks, 4 long blinks) for me meant that the OS (which was OpenElec) would not boot. I tried reformatting the card...no luck. Flashed the SD card with OSMC and VOILA it worked. I think that the code means that the OS boot files are corrupted, won't know for sure without more testing.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.