0

I' m trying to set up my raspberry pi as an wifi access spot.

While installing HostAPD and isc-dhcp-server as the guide requires, I found it unable to install anyhow, saying they' ve got unmet dependencies. Here is the information:

Some packages could not be installed. This may mean that you have
requested an impossible situation or if you are using the unstable
distribution that some required packages have not yet been created
or been moved out of Incoming.
The following information may help to resolve the situation:

The following packages have unmet dependencies:
 hostapd : Depends: libnl-route-3-200 (>= 3.2.7) but it is not going to be installed
 isc-dhcp-server : Depends: isc-dhcp-common (= 4.3.1-6+deb8u3) but 4.3.5-3+deb9u1 is to be installed
E: Unable to correct problems, you have held broken packages.

How can I solve this problem? Please help. P.S. I' ve changed the content of the file /etc/apt/source.list considering the country I am located in.

0

Already fixed guys. I mistakenly edited the source.lise file. Problem is solved after replacing "jessie" by "stretch".

| improve this answer | |
  • Thanks for giving the answer how you fixed it. You can also accept it. – Ingo May 3 '18 at 9:21

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.