0

I am trying to install Xgalaga on my raspberry pi 3. Whenever I use the command
sudo apt-get install xgalaga, The packages all install without error, however the desktop Icon file is invalid, and this is because the command that it comes with (xgalaga-hyperspace) yields a command not found error whenever it's put into a terminal.

I tried installing a few of the .deb packages from http://raspbian.raspberrypi.org/raspbian/pool/main/x/xgalaga++/, but this results in a debian version mismatch error. Forcing the install with dpkg works, but once again, no command.

I do not think that this is an error on xgalaga's side, as the invalid command also comes up when using sudo apt-get install abuse , then abuse to install and start Abuse, the 2d shooter.

I have checked my disk space, I have 7.4 GB free.

edit:

the .deb package version error's as follows: xgalaga++ : Depends: libstdc++6 (>= 5.2) but 4.9.2-10+deb8u1 is to be installed E: Unmet dependencies.

  • I tried installing a few of the .deb packages which ones? which release of raspbian are you running? stretch? jessie? buster? wheezy? – Jaromanda X May 4 '18 at 1:51
  • @JaromandaX it seems that it thinks raspbian 4.9 (jesse) is installed – tuskiomi May 4 '18 at 1:53
  • what seems to think that? you either have jessie or something else - it's you that should know what you have :p – Jaromanda X May 4 '18 at 1:54
  • @JaromandaX the disk is really old. I don't know how to check. Maybe on the startup screen? edit: it's apt-get that thinks that – tuskiomi May 4 '18 at 1:56
  • 1
    yes, I know - try running /usr/games/xglaga-hyperspace from a terminal session – Jaromanda X May 4 '18 at 2:20

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Browse other questions tagged or ask your own question.