1

I have installed Raspbian Lite on my Raspberry Pi and works perfectly except for one thing. A few Turkish characters do not appear as they should, but they appear as squares. Some of the characters that appear as square:

İ ı Ğ ğ Ş ş

How can I fix this? My locale is already TR_tr (UTF-8).

4

As you're using Lite, this is likely a console font issue. You'll need to

sudo dpkg-reconfigure console-setup

then select UTF-8, then for Character Set, choose

# Latin1 and Latin5 - western Europe and Turkic languages

You may need to reboot to see the effects of this change.

The Linux console still pretty much thinks there are only 256 places in a character set, and it has to make assumptions about the characters you want to see. These assumptions don't work for everyone, so you have to give your Raspberry Pi a hint that Turkish characters are what you want to see.

  • Thanks for your answer, it finally displays the letters right! By the way, I used TerminusBold for font (?). – pixelomer May 5 '18 at 15:21
1

If you have already updated your operating system (do it by typing "sudo apt update & upgrade), the problem seems coming from unsupported font types.

You can install fonts by downloading it from any website or use terminal to do so. It must be solving your problem as I have seen this problem for Hindi (India) fonts.

Use "sudo apt install < package name >" to install fonts.

  • I think this is the case. When I enable UTF-8 as shown in here, I still get white squares, so I definitely have UTF-8 enabled by default. When I disable it, I get weird characters. Can you give me the name of an example font package? – pixelomer May 5 '18 at 8:03
0

it might be your keyboard setting problem. You can use command on shell keyboard settings open change according to you need

  • This question has nothing to do with keyboard settings. – pixelomer May 5 '18 at 16:07

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.