2

I'm trying to set up my Raspberry Pi headless from my MacBook. However, when I flash the latest Raspian image (April 2018 version), the resulting boot partition has a read-only file system. I've tried using both Etcher and the dd utility, specifically

$ dd bs=1m if=2018-04-18-raspbian-stretch.img of=/dev/disk2

In both cases, I end up with an SD card like this:

$ diskutil list /dev/disk2 (external, physical): #: TYPE NAME SIZE IDENTIFIER 0: FDisk_partition_scheme *32.0 GB disk2 1: Windows_FAT_32 boot 45.2 MB disk2s1 2: Linux 32.0 GB disk2s2

I now want to mount the drive and put the empty ssh file in the boot directory. However, no matter what I try, I cannot modify anything on the boot directory:

$ sudo touch /Volumes/boot/ssh touch: /Volumes/boot/ssh: Read-only file system exit 1

Because of this I'm not able to ssh in and do my initial setup. I've just checked and it's the same story with the Raspbian Lite image. What am I missing?

  • 1
    mount it read/write? sudo mount /Volumes/boot -o remount,rw – Jaromanda X May 8 '18 at 23:30
  • @JaromandaX, that worked! Turned out to be a bit of a different command on my system but sudo mount -uw /Volumes/boot did the trick. I wasn't aware of remounting, thanks! – johnpaton May 9 '18 at 6:56
  • @johnpaton that command gives me mount_msdos: /dev/disk3s6 on /Volumes/boot: Permission denied – philshem Apr 16 at 12:12
  • @philshem did you use sudo? – johnpaton Apr 16 at 12:13
  • yes (but in the meantime I've hooked up a monitor and enabled ssh that way) – philshem Apr 16 at 12:56

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Browse other questions tagged or ask your own question.