2

I have carefully followed this guide in order to set up my RPi 3 as an AP. The Pi won't be connected elsewhere so I am not intending for it to provide Internet access. I only want to remotely connect to it, via WiFi through a private ad-hoc network between my laptop and Raspberry Pi.

I can "see" the new SSID on my wireless devices but I'm unable to connect to it. Moreover, if I run iwconfig I notice that the wlan0 is still attempting to connect to my router:

wlan0     IEEE 802.11  ESSID:"MyRouterSSID"  
          Mode:Managed  Frequency:2.417 GHz  Access Point: (...)
          Bit Rate=72.2 Mb/s   Tx-Power=31 dBm   
          Retry short limit:7   RTS thr:off   Fragment thr:off
          Power Management:on
          Link Quality=59/70  Signal level=-51 dBm  
          Rx invalid nwid:0  Rx invalid crypt:0  Rx invalid frag:0
          Tx excessive retries:0  Invalid misc:0   Missed beacon:0

What else should I do to enable the AP and remove previous settings?

1

The problem seemed to be caused by previous settings and the WPA supplicant service. Disabling it with:

sudo systemctl mask wpa_supplicant

and commenting the lines in /etc/network/interfaces:

allow-hotplug wlan0
iface wlan0 inet manual
#    wpa-conf /etc/wpa_supplicant/wpa_supplicant.conf

has solved the problem for now.

| improve this answer | |

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.