0

I am trying to install sli3er engine on a Raspberry Pi using this document. However, when I install the dependencies, I got an error here;

INSTALL COMMAND: sudo apt-get install libextutils-cbuilder-perl

ERROR:

Some packages could not be installed. This may mean that you have requested an impossible situation or if you are using the unstable distribution that some required packages have not yet been created or been moved out of Incoming. The following information may help to resolve the situation:

The following packages have unmet dependencies: libextutils-cbuilder-perl : Depends: perl (>= 5.13.9) but it is not going to be installed E: Unable to correct problems, you have held broken packages.

Here is the output of perl -v:

This is perl 5, version 24, subversion 1 (v5.24.1) built for arm-linux-gnueabihf-thread-multi-64int (with 80 registered patches, see perl -V for more detail)

Copyright 1987-2017, Larry Wall

Perl may be copied only under the terms of either the Artistic License or the GNU General Public License, which may be found in the Perl 5 source kit.

Complete documentation for Perl, including FAQ lists, should be found on this system using "man perl" or "perldoc perl". If you have access to the Internet, point your browser at http://www.perl.org/, the Perl Home Page.

  • Could you check the output of apt list perl? I wonder if somehow your Perl packages have got mixed up. – Aurora0001 May 12 '18 at 16:39
  • apt list perl the result is => Listing... Done perl/stable,now 5.24.1-3+deb9u3 armhf [installed] – Mehmet Bayrak May 13 '18 at 10:40

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Browse other questions tagged or ask your own question.