11

There is a 2TB Time Capsule on my home network (IP 192.168.0.1). How can I mount the Time Capsule's disk from my Raspberry Pi, automatically after reboots?

12

Put it in fstab.

sudo su
mkdir /mnt/timecapsule
echo "//timeCapsuleIp/Data /mnt/timecapsule cifs user=timecapsuleUsername,pass=timecapsuleUserPassword,rw,uid=1000,iocharset=utf8,sec=ntlm 0 0" >> /etc/fstab

Required cifs-utils package should be already provided on raspbian.

Of course change timecapsuleUsername and timecapsuleUserPassword. The uid=1000 sets owner of mounted files to user pi. If using other user check it's uid with id -u username. Check if "Data" folder is right for you - list resources by issuing command smbclient -Uusername -I ip-address -L.

  • I get this error when trying to mount: mount error(115): Operation now in progress. I can access the share fine with smbclient though. Any ideas? – Arne Jun 7 '14 at 17:03
  • Got it: I first tried with the .local name instead of the IP, does not seem to work reliably. Second, I needed to add sec=ntlm to the options. Now it works! – Arne Jun 7 '14 at 17:14
  • If Disks Secure Shared Disks With a disk password option is selected, then user= param would be ignored regardless of what it's set to – Hengjie Feb 1 '16 at 9:35
  • Just tested this on a Time Capsule running the latest (7.6.7) firmware to a Pi running OSMC. The key is the sec=ntlm and I can confirm that this works with disks secured with a device password as well as a disk password. – Gary Gale Jun 9 '16 at 14:58
5

I got adding sec=ntlm to the options, the complete command is:

sudo su
mkdir /mnt/timecapsule
echo "//timeCapsuleIp/Data /mnt/timecapsule cifs user= timecapsuleUsername,pass= timecapsuleUserPassword,rw,uid=1000,iocharset=utf8,sec=ntlm 0 0" >> /etc/fstab

Then, run this command:

mount -a

You should no get any errors.

1

Update for users of Raspberry Stretch v9. Note the addition of vers=1.0

//IPofTimeCapsule/PathWithinYourTimeCapsule /mnt/TimeCapsule cifs username=insert,password=insert,rw,uid=1000,iocharset=utf8,sec=ntlm,vers=1.0 0 0
  • What do you mean with the line beginning with //IPofTimeCapsule? – Ingo Jan 17 at 19:30
  • Sorry if I wasn't clear, I meant IP address of TimeCapsule. For example, the line might read... //192.168.1.11/Data /mnt/TimeCapsule cifs username=bsmith, password=batman, rw, uid=1000, iocharset=utf8, sec=ntlm, vers=1.0 0 0 – ddavila Jan 19 at 4:37
1

For me, when using a disk password on the time capsule, it only worked when I added uid=504 (which is the userID used on the macintosh mainly using the timecapsule, not the uid used on the raspberry). When I didn't put uid=504 then I got "mount error(16): Device or resource busy" back from the time capsule.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.