1

2 years later, I still have the same issue.

In Raspbian, using the built-in Bluetooth controller:

  • Connect a BT mouse
  • Connect a BT keyboard
  • Turn on the built-in Wifi and connect to a network

Expected behavior:

The mouse and keyboard should work properly, as anyone would expect.

Actual behavior

  • Mouse and keyboard will work intermittently and erratically.
  • Mouse and keyboard devices will will disconnect (BT led will stop blinking) seconds after the user stops using them. They will connect againg (wake up) eventually and unpredictably.

Interestingly enough, the wrong behavior disappears as soon as the Wifi controller is turned off.

How can I fix this?

  • What is the power source you are using . Would be good more than 2,5 AMPs – E_Angel May 16 '18 at 10:11
  • Yes, I'm using a recommended power source :) 3 AMPs – SuperJMN May 16 '18 at 15:01
1

The only solution would be to get external bluetooth / WiFi adapter, as the modules on RPI share antena path :(

| improve this answer | |
  • I don't think so. Using the same Raspberry Pi 3, but with Windows 10 IoT Core, I've been able to use both mouse and keyboard without a hitch. The 2 devices work perfectly at the same time, whereas in Raspbian doesn't. I do believe that it's not a hardware thing. – SuperJMN May 16 '18 at 15:04
0

This is far from a perfect solution, but it works for me and I can now connect to WIFI while using a bluetooth keyboard - no dongle!

Preparation steps:

  1. Set your WIFI/Hotspot to 5G mode on your modem/cellphone so that WIFI does not conflicting the 2.4G bluetooth connection on Raspberry PI

  2. Create a new text file in home foler, put the codes in, replace XX:XX:XX:XX:XX:XX with the address of your own bluetooth device, save, change the file name to .pingbluetooth.sh

    until [ "f" != "f" ]; do

    sudo l2ping -c 1 XX:XX:XX:XX:XX:XX
    
    sleep 0.5
    

    done

You'll need to go through the following steps every time after the system is rebooted. It's a pain but it's working, at least for me.

  1. Turn off WIFI on Raspberry PI

  2. Connect to bluetooth keyboard on Raspberry PI. You'll have to connect to bluetooth device before WIFI.

  3. Run the command in terminal, this will keep the bluetooth connection from dropping off.

    bash ./.pingbluetooth.sh

  4. Turn on WIFI on Raspberry PI and connect to the 5G network that you already set up.

In fact, before I upgraded the system recently, I did not need to change WIFI to 5G mode, did not need to connect bluetooth before WIFI. Not sure what happened in the upgrade.

| improve this answer | |

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.