3

I've followed the instructions to "force sound over 3.5mm jack" but when I run omxplayer example.mp3 I get no audio. When I force omxplayer to play over the 3.5mm jack using omxplayer -o local example.mp3 it works. How do I change the system-wide default to 3.5mm so when I run omxplayer example.mp3 (or play audio through another app) it works?

  • 1
    set up an alias alias omxplayer="omxplayer -o local " – jsotola May 13 '18 at 20:13
  • Thanks, but I'm not actually interested in omxplayer. I'm just using that to debug. I want audio to work in other apps. – Tyler May 13 '18 at 20:42
  • 1
    not actually interested in omxplayer ...your post implies otherwise – jsotola May 13 '18 at 23:55
0

The Raspberry Pi documentation covers three ways to force audio. Try the first two methods:

  1. Desktop volume control
    Right-clicking the volume icon on the desktop taskbar brings up the audio output selector;

  2. Command line
    This command will switch the audio output to HDMI:

    amixer cset numid=3 2
    

    Here the output is being set to 2, which is HDMI. Setting the output to 1 switches to analogue (headphone jack). The default setting is 0 which is automatic.

  3. raspi-config
    Go to Advanced -> Audio, HDMI and analogue should appear here

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.