I am trying to add OpenCV lib on PyCharm running under Raspbian on a Rpi 3 model B. I tried the jessie version of commands but got stuck on the

    -D CMAKE_INSTALL_PREFIX=/usr/local \
    -D OPENCV_EXTRA_MODULES_PATH=~/opencv_contrib/modules \

Got the message:

CMake Error: The source directory "/home/pi/BUILD_EXAMPLES=ON" does not exist.

Specify --help for usage, or press the help button on the CMake GUI.

I am new to Raspberry Pi and never played with the jessie version of Raspbian (using Strech). I am almost sure it might be a usage error from my ignorance on the language.

  • 1
    I have tried to install PyCharn on my RasPi 400. It worked, but PyCharm need much more juice than the Pi can provide. It is very slow and barely usable. I would reccomend you to Not do it. Feb 10, 2021 at 9:59

1 Answer 1


I don't have old stable version jessie running but usually you find libopencv* in the default Raspbian repositories. Look with apt list libopencv* if it is available in jessie. If so you can simply install the libraries you need. There is no need to compile OpenCV from source, unless you must use a newer version.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.

Not the answer you're looking for? Browse other questions tagged or ask your own question.