0

I have a new Raspberry Pi 3 Model B. It has been working fine with the keyboard and mouse. I have ran rpi-update since purchasing it and it continued to work fine after that. I have tried starting the Raspberry Pi with the keyboard and mouse off with the wireless USB receivers plugged in. I have tried starting the Pi with the USB receivers out and then plugging them in. Neither results in the keyboard working. My Pi is setup to boot to the command line. I have also tried plugging the micro USB power adapater into a different outlet in my home. This still results in the thunderbolt icon appearing.

I am not sure what to do next to troubleshoot the problem. Should I just try to return it?

EDIT: Duplicate question w/ answer which I could not find before - RPi undervoltage

  • What operating system are you using, and which version? – NomadMaker May 17 '18 at 3:42
  • This is a duplicate question. It means a low-power condition. Either your power supply has gone bad, or you need a better cable. – NomadMaker May 17 '18 at 3:45
  • I know that the thunderbolt means there is a low power condition. I looked that up. But why is it that way when it worked before with everything else the same and trying a different outlet? A short or something could also cause the power to be low, right? If there is something I could fix then I would like to figure that out. I just bought a 3 and I ran rpi-update. So you tell me what OS version I am on? I clearly cannot execute the command on the device. – Sophie May 17 '18 at 4:13
  • Power supplies go bad over time. I asked you for the operating system because it's something that is useful to answer most questions. Your OS is probably Raspian. Also, you need to show your research in your question. You should have defined what the lightning bolt meant. This would have saved me from looking it up. – NomadMaker May 17 '18 at 4:21
2

Running rpi-update is NOT RECOMMENDED - it probably has nothing to do with your problem, but who knows what is in the latest test version. (The Pi3B+ has different power circuitry which needs different firmware to support power indication - I would not be surprised if this has been changed.)

"In normal circumstances there is NEVER a need to run rpi-update as it always gets you to the leading edge firmware and kernel and because that may be a testing version it could leave your RPi unbootable". https://www.raspberrypi.org/forums/viewtopic.php?p=916911#p916911 Even the rpi-update documentation now warns "Even on Raspbian you should only use this with a good reason. This gets you the latest bleeding edge kernel/firmware."
sudo apt-get update; sudo apt-get install --reinstall raspberrypi-bootloader raspberrypi-kernel will put it back to the latest supported kernel/bootcode.

Your problem will be power supply AND/OR cable See Raspberry Pi Power Limitations

The thunderbolt DOES NOT mean low power - it means the voltage is low.

Your question is not entirely clear, but you seem to be using USB peripherals which often cause power problems.

The ONLY way to be sure is to measure voltage.

  • Thank you for your detailed response. I have been able to test voltage now on pins 2 and 6 when starting the Pi up. At first it is at 4.93V and then soon goes to 5.05V. The highest voltage during boot is 5.10. These readings come when the thunderbolt is present. – Sophie May 19 '18 at 21:05
  • To your recommendation, I also purchased a better power supply. That is not fixing the problem either. There is some kind of failure that appears in the boot console but I cannot read it before it is pushed off the screen. I have tried capturing it on video but the camera is never in focus that early. – Sophie May 19 '18 at 21:09

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.