0

I'm done flashing and trying it on both Jessie and the latest stretch version of Raspbian.

Also, I am well aware that after 2016 releases, we need to add a SSH empty file in root directory. Still, it's not working.

I did following:

  1. Flashed raspbian on Sd card using Etcher.
  2. Add Empty SSH file( i have taken care of .txt extension).
  3. Assigned IP address to my ethernet connected pi(also tried autoconfiguration mode or auto assign by windows)
  4. Also checked through angryip and scanip scanners in range
  5. Tried logging in through ssh through putty.

---- No success :(

I' also tried using an external DHCP server from http://www.dhcpserver.de/cms/

No success. Spent almost continuous 10 hrs, & I don't have a monitor/screen. Went through common threads and pages...

  • Can you ping the ip address you assigned the rpi? – eftshift0 May 17 '18 at 17:10
  • Hello eftshift0, Yes I can ping ! – Rachit May 17 '18 at 17:10
  • Then it's about the ssh service not starting. Can you tell us the process you followed to create the ssh file on the boot partition? – eftshift0 May 17 '18 at 17:16
  • After flashing SD card, I added an empty text file named: "ssh". Made sure to remove .txt extension. Inserted the sd card in pi and ran it. My cmdline file shows the following output: dwc_otg.lpm_enable=0 console=serial0,115200 console=tty1 root=PARTUUID=9cba179a-02 rootfstype=ext4 elevator=deadline fsck.repair=yes rootwait quiet splash plymouth.ignore-serial-consoles – Rachit May 17 '18 at 17:31
  • So.. the ssh file is created theoretically at the right spot, you insert the card into the rpi, ssh still doesn't work. What happens if you take out the card and put it back in the computer? Is the ssh file still there? If the file is still there, then you are probably doing something wrong (either the file is not named correctly, or it's placed at the wrong location..... something simple. It's ssh, all in lowercase, right?). – eftshift0 May 17 '18 at 18:09

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Browse other questions tagged or ask your own question.