0

When trying to initialize the Piface Relay+ with:

pfr = pifacerelayplus.PiFaceRelayPlus(pifacerelayplus.RELAY)

I get these errors:

Traceback (most recent call last):
  File "/home/pi/Documents/pifacerelayplus-master/examples/blink.py", line 9, in <module>
    pfr = pifacerelayplus.PiFaceRelayPlus(pifacerelayplus.RELAY)
  File "/usr/lib/python3/dist-packages/pifacerelayplus/core.py", line 248, in __init__
    self.init_board(gpioa_conf, gpiob_conf)
  File "/usr/lib/python3/dist-packages/pifacerelayplus/core.py", line 281, in init_board
    c=self.chip_select))
pifacerelayplus.core.NoPiFaceRelayPlusDetectedError: No PiFace Relay+ board detected (hardware_addr=0, bus=0, chip_select=0).`

My address jumpers are in the right place, SPI is enabled and I have the Python 3 libraries for Piface Relay+.

I'm using a RP3 Model B+. Pretty new to Raspberry Pis in general so would like to know why it won't find the PiFace.

1

I have just had the exact same problem and emailed support who told me the issue is to do with upstream packages and they are planning on getting it fixed. Please see the link below for a quick fix.

https://github.com/piface/pifacecommon/commit/d4c568926e49dc75a983e2fed41b79ebf317b10d?diff=unified

Edit the spi.py file in the referenced directory.

  • Posted an explanation how i solved my issue. Don't know if we have the same issue so i don't know if it will help. – Adam Andersson Aug 3 '18 at 18:16
0

Explained how i solved this issue in the pifacerelayplus gitHub page. https://github.com/piface/pifacerelayplus/issues/8

Manually installing the most recent python3 distribution packages for pifacerelayplus and pifacerelay common solved it for me.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.