2

I have a number of images shown for my wallpaper in preferences but whatever I click on, does not change the wallpaper.

I want to go back to the Raspberry Pi image and when I click on that image nothing changes.

If these pictures are corrupt, I have a jpeg of the pi image but I do not know how to load it. I would try this if there is no solution to the existing images but don't know how to do that. Sorry for being long winded. I am a newbie! Thanks in advance for your help!

1

So here is the solution for Raspbian Stretch

pcmanfm --set-wallpaper yourfile.jpg

The file can be on any path that is available to read by the user. Here I have assumed it to be /home/pi.

| improve this answer | |
1

This answer is based on Buster, so Jessie may be a bit different.

Pcmanfm sets its wallpaper based on what the config file tells it to. The config file is located at /home/pi/.config/pcmanfm/LXDE-pi/desktop-items-0.conf.

Simply change the wallpaper= line to the full path of the image you want.

| improve this answer | |
0

You change the Picture in Preferences/Appearance Settings/Desktop/Pictures

I use /usr/share/raspberrypi-artwork/raspberry-pi-logo-small.png.

I Am not sure if jpeg works, most use png

| improve this answer | |
  • Thank you for your response. I have tried going to the location you suggested. I have the png logo listed as an option but selecting it does not change the wallpaper. I tried going back to the defaults and it lists a different wallpaper but it still does not change from the existing wallpaper. – Larry C May 20 '18 at 17:54
  • Thank you for your suggestion. I will try it the next time I log in and let you know if it works. Thanks again. – Larry C Dec 7 '19 at 21:30

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.