0

I am using Adafruit i2s Mems Microphone on Raspberry pi3 and PocketSphinx for the Speech to text conversion project. I am able to record audio on AUDACITY and Alsa. Previously i tried Google speech API but couldnot resolve the ** "Error -400" ** (If can resolve this then this will be a great help for my project <3).

Parllely i was trying PocketSphinx that time i was not able to properly install, Right now i am on right track, Thank you Community.
RIght now I am getting an error and i tried a solution also.

"Error opening audio device default for capture: No such file or directory
FATAL: "continuous.c", line 245: Failed to open audio device"

Solution

sudo apt-get remove pulseaudio -y
sudo aptitude purge pulseaudio -y
sudo mv /usr/include/pulse/pulseaudio.h /usr/include/pulse/pulseaudio.h.old

But nothing seems working.

Can you please help and tech me regarding I2S microphone.

The problem above is solved but still stuck in new problem

The command is working for

pocketsphinx_continuous -inmic yes -adcdev plughw:1,0 but not Pocketsphinx not working

INFO: continuous.c(307): pocketsphinx_continuous COMPILED ON: May 21 2018, AT: 17:24:31 INFO: continuous.c(252): Ready.... ^C

  • Could you share what code was generating the 400 error? 400 means bad request error, so you url arguments were probably incorrect. – scitronboy May 21 '18 at 16:00
  • cloud.google.com/speech-to-text/docs/streaming-recognize on this page "Performing Streaming Speech Recognition on an Audio Stream" section code. which is Speech Api's Python Example. where you think i am going wrong? – Hitesh Patil May 21 '18 at 16:10
  • there no links in the code. and i am not sure configuration file. – Hitesh Patil May 21 '18 at 18:52

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Browse other questions tagged or ask your own question.