1

I am using UART sensors that do not allow the RPI to finish the boot when the serial console and the bluetooth are on. I did disable them using the dtoverlay=pi3-disable-bt in /boot/config.txt and deleted the serial console parameters from the /boot/cmdline.txt, but the problem is that they are still on during the boot and they only get disabled after, which does not allow my pi to boot when I have my UART sensors plugged in. Does anyone know how this could be fixed?

EDIT: It might be that my pi does not boot because the sensors connected send garbage to the board, which cause my u-boot to stop at hit any key to stop u-boot, hence I am thinking that setting that key to something pre-defined instead of "any key" could solve my problem. However, I don't know how to do that, could anyone help?

Thank you

  • sensors connected send garbage .... the "garbage" could still contain the predefined key press – jsotola May 22 '18 at 17:33
1

I managed to solve the problem. I modified the u-boot variable setenv stdin nulldev, setting a pre-defined u-boot stop key or setting bootdelay = 0 did not solve my problem.

Hope this helps.

1

You can solve this by setting the bootdelay of u-boot to -2 using the u-boot console:

setenv bootdelay=-2
saveenv

Another solution is adding these lines of code to include/configs/rpi.h:

#define CONFIG_AUTOBOOT_KEYED
#define CONFIG_AUTOBOOT_PROMPT "\nRPi booting... Stop with ENTER\n"
#define CONFIG_AUTOBOOT_DELAY_STR "\r"

See also here.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.