0

I am very new to raspberry pi in general so if all responses could not assume any prior knowledge that would be fantastic!

My problem is, I am following the steps to install the Google Assistant module on my Magic Mirror and I'm running into a problem that hopefully someone can help with.

I have followed step by step from here and the problem i'm running into is after downloading the .js filed for the OAuth they say rename the file as secret.js and place in my MMM-Assistant directory, which I just moved the file from my Downloads folder to MagicMirror/modules/MMM-Assistant folder.

Then it says "Then execute this on your MagicMirror terminal.(not via SSH)"

So, I type in /home/pi/MagicMirror/modules/MMM-Assistant/secret.json and it says permission denied. So I tried to just skip that and go to the next where it says cd <Your MagicMirror Direcotry>/modules/MMM-Assistant/scripts/ node google-auth.js it then says too many arguments. And no browser opens to give me credentials.

If someone could please help me out that would be fantastic. I've tried doing sudo bash and then the commands but it still says permission denied and I'm stuck.

0

Here's an explanation of the errors you were getting: permission denied errors are typically caused by one of two reasons: either you don't have permission to run that file(in which case using sudo should fix it) or the file simply cannot be executed. json files are not executable, that is, they are simply data files. The second error you got, too many arguments, was caused by running the cd command with 3 arguments: /modules/MMM-Assistant/scripts/, node, and google-auth.js. This throws an error because cd requires only one argument: the directory to change into.

So your problem is simply not understanding the instructions correctly:

After renaming client-secret-blahblahXXX.json to secret.json and putting it in the MMM-Assistant directory, you need to execute the following commands(seperately):

cd <Your MagicMirror Direcotry>/modules/MMM-Assistant/scripts/

then

node google-auth.js

Don't do them together.

4
  • Ahh, makes sense..I appreciate the explanation and you dumbing it down for me! Ill give it a shot here soon.
    – Meisch
    May 24 '18 at 21:27
  • I just tried it, went to the scripts directory within MMM-Assistant and now it's saying it can't find module MagicMirror/modules/MMM-Assistant/assets/google-client-secret.json'...any thoughts on this? I tried moving it to this folder and trying again but nothing, Sorry I'm so needy
    – Meisch
    May 24 '18 at 23:04
  • @Jacob , try moving secret.json into MMM-Assistant/assets and renaming it to google-client-secret.json
    – scitronboy
    May 24 '18 at 23:07
  • I tried renaming it and leaving it in the MMM-Assistant directory and it didn't work but that just did, thank you so much!
    – Meisch
    May 24 '18 at 23:11

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.