1

On Jessie, with the Rpi3B, it is simple to enable xrdp:

sudo apt-get update
sudo apt-get install xrdp

badda bing.


But with the new Rpi3B+ which requires Stretch, it has a problem.

It will still allow you to get to the login screen, but then after supplying the credentials it then goes to a blank screen.

How to make xrdp work with Stretch on the new Rpi3B+?

0

This is actually unrelated to the new hardware.

Turns out that Stretch comes with RealVNC server installed. Stretch will run on either 3B or 3B+ systems. To use VNC, enable it in raspi-config and use a RealVNC client for access.


But this conflicts with xrdp

To fix the problem and make it work, simply remove RealVNC server.

sudo apt-get update
sudo apt-get purge realvnc-vnc-server

And voila, RDP access works normally on Stretch.


Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.