1

I have an issue and I think it is the SPI module not starting up. if i run this:

pi@raspberrypi:~ $ gpio load spi
gpio: Unable to load/unload modules as this Pi has the device tree enabled.
  You need to run the raspi-config program (as root) and select the
  modules (SPI or I2C) that you wish to load/unload there and reboot.

However, it is all enabled!

I have even added it to the /etc/modules file

# /etc/modules: kernel modules to load at boot time.
#
# This file contains the names of kernel modules that should be loaded
# at boot time, one per line. Lines beginning with "#" are ignored.

i2c-dev
i2c-bcm2708
spi-dev

Also, testing my spi works:

pi@raspberrypi:~ $ ls /dev/*spi*
/dev/spidev0.0  /dev/spidev0.1

However, when I run a program that I know works on a RPi Model B to operate some WS2801s nothing happens.

1

You should undo all that configuration and use device tree. Other methods have been deprecated for several years.

Edit /boot/config.txt and add the following entry, then reboot.

dtparam=spi=on

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.