0

I'm trying to configure the DNS settings of a Fritz!box 3490 so that the host names are revealed in Pihole.

  • Fritz is DHCP server
  • WAN DNS set to Pihole (DSL)
  • DHCP DNS forward to Pihole (Local Network)
  • Pihole knows the router IP and domain name

I've tried only setting the WAN DNS to the Pihole and leaving the DHCP to the Fritz.

Unless static IP and DNS is set, network device requests show as coming from the Fritz. freepentester has static IP and forced DNS to the Pihole

0

In order to resolve the queries from the network devices in the pihole WebGUI, the clients' requests have to come to the pihole directly and not via the Fritzbox.

Therefore you should set the Fritzbox as primary DNS on the pihole, give the pi a static IP and set the pihole as DHCP server. It might also be helpful to uncheck "Never forward non-FQDN" in the pihole settings.

FYI: The Fritzbox doesn't support DNS resolution of private IP addresses (https://en.avm.de/service/fritzbox/fritzbox-7390/knowledge-base/publication/show/663_No-DNS-resolution-of-private-IP-addresses/).

  • 1
    There is an option on the Fritz!box to turn off DNS rebind and add allowed domains, fritz.dns being the default. I don't really want the Raspberry Pi to be the DHCP server as it is not as suited to the job compared to the Fritz. – Andy Anderson May 28 '18 at 19:13
0

Resolved: kept the Fritz!box as DHCP server. Set the Pihole as DNS server in local network IPv4 area and as both of the DNS in DSL account section on the Fritz!box. Pihole for me has 'unbound' setup so the upstream DNS server was set to 127.0.0.1#53. Side note - if you set a device with static IP (including Pihole as DNS) it also shows up without changing everything.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.