0

I purchased two cheap OLED modules, one is 0.96" 128x32 I2C at the following link: https://www.amazon.it/gp/product/B06XRBTBTB/

and the other is a 2.4" 128x64 at the following link: https://www.amazon.it/gp/product/B0749DYGSW/

I got the first to work with the Adafruit SSD1306 library (I followed this guide). The problem comes with the second one, 'cause I cannot understand if it requires I2C or SPI. I tried to wire only 4 of it's 7 pin in I2C mode (VCC, GND, SDA, SCL) like the first, but it's not working (i2cdetect -y 1 command does not show any attached device). I also tried to follow this guide and wire it in SPI mode, but with no result. Did someone managed to make this kind of OLED work? The pins on this module are the following:

  • CS
  • DC
  • RES
  • SDA
  • SCL
  • VCC
  • GND
  • It might be a 5V module. – Janka May 31 '18 at 9:57
  • it's a 3.0 to 5.5V. I connected it to the 5V pin. – user2959923 Jun 1 '18 at 8:15
  • That's the problem. The Raspi is a 3.3V device and wants 3.3V on its GPIO socket I²C pins exclusively. The only 5V I²C it has is on the HDMI connector. – Janka Jun 1 '18 at 9:48
  • Well, I tried to connect it to the 3.3V pin, still not working. – user2959923 Jun 1 '18 at 13:40

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Browse other questions tagged or ask your own question.