0

I have set up a virtual device in asoundrc which works in Audacity but when I open it using the Chromium --alsa-input-device flag I get the following error:

Rate doesn't match (requested 48000Hz, get 16000hz)

I am using a Playstation eye and if I open Chromium normally and select it from the device list (USB camera - b4.09.24.1, usb audio...) it works fine. My asoundrc looks like the following:

pcm.ps {
    type hw
    card 3
}

pcm.ps1 {
    type route
    slave.pcm ps
    slave.channels 4
    ttable.0.0 1
    ttable.1.0 1
} 

The Playstation eye apparently has a sample rate of 48000. I have tried using the Chromium flag --alsa-enable-upsampling=true but this doesn't seem to do anything.

Is there a way to fix the sample rate problem or is there a way to have my virtual device appear in Chromium's microphone device list in chrome://settings?

Many Thanks,

S

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Browse other questions tagged or ask your own question.