1


I am planning to use an external Microphone "ReSpeaker 4Mic Hat" from Seeed-Studio on my RPi3 B+ Stretch OS. However, when I run alsamixer, my external Mic is not the default capture device. It seems like bcm2835 is the default soundcard, which means as default I don't have any capture device.
If I launch audacity, I can successfully record sound with the external microphone.
So, where I can set the default setting for Alsa like: Default Input: "hw1,0", default output: "hw0,0"?

0

If you have not resolved this, check here: http://wiki.seeedstudio.com/ReSpeaker_4_Mic_Array_for_Raspberry_Pi/

It says: "If we want to change the alsa settings, we can use sudo alsactl --file=ac108_asound.state store to save it. And when we need to use the settings again, copy it to: sudo cp ~/seeed-voicecard/ac108_asound.state /var/lib/alsa/asound.state"

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.