3

I've tried to install some packages files in my RPi but i dont know how. The files comes from here: http://mirrordirector.raspbian.org/raspbian/dists/wheezy/main/

And they're .gz .bz2 and other without extension just come Package and nothing more.

I have a several files like that but i can't install with commands that i know like.

sudo dpkg -i name.deb

Obs: They aren't .tar.gz is just .gz

  • 4
    get an internet connection and use apt-get to install the packages you need. trying to do this manually will lead to many hours spent in pain and frustration. – lenik Jul 16 '13 at 22:29
  • My RPi is MODEL A and haven't ethernet socket. – Edilson Jul 17 '13 at 14:06
  • USB Wifi adapter should work just fine in your case. – lenik Jul 17 '13 at 15:37
  • I already tried it, but at momment my wifi is ad-hoc and dont work. Thanks at same. – Edilson Jul 17 '13 at 16:41
1

There are two ways to do this. Install the files from deb, or get the internet working, or both. I've grabbed my files for the raspberry pi from here in the past with great success. I then open a terminal and, in the same folder the file has been downloaded into, typed dpkg -i name.deb.

You must be in the same folder as the file - the easiest way to do this is to maneuver there in the file manager and right click then select 'open terminal here.'

I used files from this site to get my mobile phone working as either a source of internet, or as a wifi dongle (I have an android - but it should be the same for any phone that you can tether).

You will need a computer with the internet (presumably you have this to get the tarballs you mentioned.

Step 1: Download libpcap0.8, ppp and pppoeconf (sorry, I don't have enough reputation to post another direct link, but ppp and pppoeconf are in /main/p/ppp/ on the same server - I added the direct links in a comment below).

Step 2: Open LXTerminal in the same folder where you have the files saved and type dpkg -i libpcap then press the 'Tab' button (the rest of the name should auto-complete - if not, then you'll have to type it in full (or copy and paste the name).

Step 3: Do the same for ppp and pppoeconf.

Step 4: Open LXTerminal in the root folder and type: sudo leafpad /root/interfaces.txt and add the following line: iface usb0 inet dhcp then save and quit.

Step 5: Enter ifup usb0 in the terminal

Step 6: Make sure your phone is connected, and tethering is switched on.

Step 7: Type sudo ppoeconf and follow the prompts

Step 8: Reboot.

You should now have networking (or at least I did). You can now apt-get install wicd which will give you better access to your networking.

Step 9: Open wicd, and from the drop down menu on the right select 'preferences' and replace eth0 with usb0 in the wired interface box. Tick the 'always show wired interface' box.

You can also turn wireless on and use your phone as a wireless dongle - just as handy, but without using your bandwidth.

0

Most packages are available in the Debian Software repositories, easily accessible through the command sudo apt-get install *package_name* If you are trying to install something that is not in the repositories, the specific instructions should be provided by the developer, but .deb files should be easily installed with dpkg. .tar.gz packages typically need to be compiled before they can be run. Generally they can be compiled by following the directions on installing tarballs many places on the net.

  • I already tried to install. deb files but ask me another files like libs etc, and i haven't all of them. And my RPi dont have internet. – Edilson Jul 16 '13 at 18:47
  • 2
    @Edilson This post a few days ago may be of interest – Butters Jul 16 '13 at 18:58
  • @ Butters i already have internet connection from an wifi. – Edilson Aug 16 '13 at 7:45
  • @Edilson Since you now have internet, to install apache for example run the command sudo apt-get install apache2. Do some research into the software repositories so you know what is actually happening. – Butters Aug 16 '13 at 13:12
  • i already know where found their names and how to install them ^_^, but thanks at same. – Edilson Aug 16 '13 at 15:57

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.