I recently acquired a brand new RPi Model 3 B+ and decided to try and install Retropie (v4.4) on it. I managed it to boot properly and I got a PS3 controller to work via USB.

The problem is that I continuously see the under voltage warning and sometimes the system lags down a little and I suspect this is the cause. I'm currently feeding the RPi with 5V, 2A. Are the amps the problem?


2 Answers 2


Given that the under voltage warning is being showed it sounds highly likely that the power supply is inadequate.

It seems likely that it can not supply the current (amps) needed by the Pi and the peripherals and as a consequence the supply voltage is dropping.

You need a 5V power supply which is rated at a higher maximum current.


I had same problem, tried several different power supplies and about 8 different cords. nothing worked. I think the problem is the voltage drop in the usb connection. I purchased a thicker wired in supply and works great- no issues at all. Used for over an hour


Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.

Not the answer you're looking for? Browse other questions tagged or ask your own question.