0

With my Mac I used to backup .jpg and .NEF (Nikon raw files) on a WD MyBook World Edition II network drive.

After a few months I was not using it, I discovered it was not working anymore. On the WD MyBook there were two 1Tb HDs, RAID1, I took them out from the WD case and tried to recover files from any of them with my MacBook and an external cable: the first one just made a horrible noise and didn't show at all, the other seemed to work, but I couldn't recover the files.

Reading on the internet, I discovered that the HDs were formatted with Linux File System (if this make any sense), so I thought that I could read the second one as an external HD, connecting to my Raspberry Pi Zero W, with the latest Raspbian OS on it, recovering then the files and copying them on another HD.

The problem is that the last time I had to deal with Linux was around 1995, I can't even remember how to read a directory. When the external unit is connected I can't see it on top right menu as a drive.

But, if I write "dmesg", I can see this:

[ 999.436182] usb 1-1.2.4: New USB device strings: Mfr=1, Product=2,

SerialNumber=3  
[  999.436189] usb 1-1.2.4: Product: Mass Storage Device  
[  999.436196] usb 1-1.2.4: Manufacturer: Generic  
[  999.436203] usb 1-1.2.4: SerialNumber: 058F0O1111B1  
[  999.439956] usb-storage 1-1.2.4:1.0: USB Mass Storage device detected  
[  999.454270] scsi host0: usb-storage 1-1.2.4:1.0  
[ 1000.485423] scsi 0:0:0:0: Direct-Access     Multi    Flash Reader     1.00 PQ: 0 ANSI: 0  
[ 1000.498640] sd 0:0:0:0: [sda] Attached SCSI removable disk  
[ 1000.499101] sd 0:0:0:0: Attached scsi generic sg0 type 0  
[ 1011.785368] usb 1-1.2.2: new high-speed USB device number 11 using dwc_otg  
[ 1011.915572] usb 1-1.2.2: New USB device found,idVendor=152d, idProduct=0539  
[ 1011.915599] usb 1-1.2.2: New USB device strings: Mfr=1, Product=2, SerialNumber=5  
[ 1011.915612] usb 1-1.2.2: Product: USB to ATA/ATAPI Bridge  
[ 1011.915622] usb 1-1.2.2: Manufacturer: JMicron [ 1011.915633] usb 1-1.2.2: SerialNumber: DCA40926430F  
[ 1011.922760] usb-storage 1-1.2.2:1.0: USB Mass Storage device detected  
[ 1011.954071] scsi host1: usb-storage 1-1.2.2:1.0  
[ 1012.965095] scsi 1:0:0:0: Direct-Access     WDC WD10 EAVS-00D7B0           PQ: 0 ANSI: 2 CCS  
[ 1012.972099] sd 1:0:0:0: [sdb] 1953525168 512-byte logical blocks: (1.00 TB/932 GiB)  
[ 1012.973629] sd 1:0:0:0: [sdb] Write Protect is off [ 1012.973657] sd 1:0:0:0: [sdb] Mode Sense: 28 00 00 00  
[ 1012.984638] sd 1:0:0:0: Attached scsi generic sg1 type 0  
[ 1012.985377] sd 1:0:0:0: [sdb] No Caching mode page found  
[ 1012.985403] sd 1:0:0:0: [sdb] Assuming drive cache: write through  
[ 1013.020471]  sdb: sdb1 sdb2 sdb3 sdb4  
[ 1013.025719] sd 1:0:0:0: [sdb] Attached SCSI disk

Any suggestion on how to mount the disk to see what's inside, or on which software should I use to recover files from that HD?

I tried this to mount the HD:

Device     Boot   Start        End    Sectors   Size Id Type  
/dev/sdb1 48195   5927984    5879790   2.8G fd Linux raid autodetect  
/dev/sdb2 5927985 6136829     208845   102M fd Linux raid autodetect  
/dev/sdb3 6136830 8112824    1975995 964.9M fd Linux raid autodetect 
/dev/sdb4 8112825 1953520064 1945407240 927.7G fd Linux raid autodetect  
pi@raspberrypi:~ $ sudo mkdir /mnt/usbhdd  
pi@raspberrypi:~ $ sudo chmod 777 /mnt/usbhdd  
pi@raspberrypi:~ $ sudo mount /dev/sdb4 /mnt/usbhdd

But I just got this:

mount: unknown filesystem type 'linux_raid_member'

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Browse other questions tagged or ask your own question.