0

I'm using Raspbian Stretch Desktop for my Raspberry Pi 3B.

I'm using a VGA screen with an HDMI to VGA adapter, so I want the jack to work as my main audio output. If I unplug the HDMI and reboot, the speakers work as intended, but whenever I plug it, they stop working because the audio output is sent through the HDMI.

What I want is to force the audio output to be through the jack. Since doing it from sudo raspi-config menu didn't work, I tried what lots of people in lots of forums say, and I used this command:

amixer -c 0 cset numid=3 1

But it doesn't work for me (I tried with every posible number combination, just in case). I also uninstalled pulseaudio because someone said it may be a workaround to the problem, but it didn't work either.

Notice: I rebooted the RPi a lot of times while trying this.

Does anyone have any idea of what the problem is and how can I solve it?

.

SOLUTION:

The problem was with omxplayer. It seems to ignore the configuration and use its own. Fixed!

2

If you are on Raspbian, Run

sudo raspi-config

Navigate to 7 Advanced Options => A4 Audio => Force 3.5mm ('headphone') jack, save and reboot.

  • This was the first thing I tried... Forgot to mention it. Thanks anyway. – Javito Jun 12 '18 at 7:33

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.