1

Problem: I have a working sd card, a working rpi, and working power supply. When I then plug in an ethernet cable into the rpi and reconnect the power supply to a power bar (where I have 3 other rpi's connected) rather than from a socket from the wall, the rpi then does not boot and only shows the red led and a black screen.

Setting-up the rpi again without the ethernet cable and with the power supply again connected to a socket in the wall shows the same, only red LED and black screen.

Removing the sd card and plugging it into one of the working rpi's (say "pi04"), that are also connected to the same type of power cable (original rpi) connected to the power bar and the same type of ethernet cable, shows rainbow screen forever.

Doing the opposite, so plugging in a working sd card (from pi04) into the 'broken' rpi, either from the wall or not shows rainbow screen forever. Replugging in that sd card back into pi04 makes pi04 boot up again.

Because I am working on a larger project for 10rpi's I had a number of them available to try. I have tried 4 rpi's and they all show above behaviour, then bought two new rpi's with which the same happened (worked initiall but after connecting to the set-up as above stopped working completely), meaning I now have a total of 7! rpi's that only show the red LED and never boot (black screen)...

I have tried with different types of new sd cards, fresh raspbian and noob installations, and official rpi power cable and two alternatives. Nothing works. I am completely lost as I have tried everything and went through all the troubleshoot documents and steps.

I don't understand how this can so easily happen with standard rpi power cable, sd card, ethernet cable and power bar available. As I mentioned I have now 7 rpi's that do not do anything, which is becoming very very costly..

a) Could it be that the ethernet cable has a kink in it and thereby short-circuits the rpi, breaking it as well as the sd card? b) Or could it be that the power plug in the powerbar is somehow wrong (while the other plugs in the bar work correctly) and thereby overpowers the rpi and breaks it as well as the sd card? I am confused as the red light does show.

I have been able to isolate the issue to the specific location with ethernet cable and the power bar, but every try I do costs me a rpi and sd card!

I sincerely hope there is somebody here that can help me further. I know these types of questions are asked a lot but I have checked all relevant webpages and tried that so really need someone with further knowledge.

Thank you.

  • Is it a solid red light, or flashing? Do your Pi's symptoms match any of the options listed here? If you have a multimeter handy, perhaps you could also try checking the power. – Aurora0001 Jun 11 '18 at 18:05
  • It is a solid red light, no green light at all. It is a rpi 3 and checking with multimeter showed 5.0, although the guide shows it for the original rpi. Checked everything in the link you shared but nothing works. Different sd card that works in other rpi does not work; different power cable that works with other rpi does not work etc.. Any other ideas? Could it have to do with a broken ethernet cable? What can I do with all the broken rpi' – crazjo Jun 11 '18 at 18:57
1

I had a similar situation a few weeks ago where my Raspberry Pi 3B+ had a red LED only and a black screen. I tried a new SD card with NOOBS with no luck.

I read somewhere that the rainbow screen loads from the Raspberry OS files on the SD card, because there's no onboard firmware/storage/software.

I discovered that I had shorted my 5V pin to one (or more) other random pins due to some faulty solder job. I suppose I had fried the Raspberry Pi's voltage regulator which provides power for the 3V3, CPU, and other chips.

I assume because the regulator chip (label MXL7704 near the USB input) was physically hot after a few minutes, and with a multi-meter I measured no voltage on the 3V3 pins. 5V on pins 2 and 4 was still present since it comes directly from the USB supply.

I had to purchase a new Raspberry Pi.

Just my experience.

0

The ethernet chip is increasing the power consumption witch could cause what you describe.

There is a lot of article, forum postings and first hand experience that will tell you that the voltage drop caused by cables with small areas and power supplies that is to close to the minimum voltage causing the problems you describe.

Check this https://www.youtube.com/watch?v=n70N_sBYepQ for a more in-depth description.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.