1

I've installed Retro Pie and I would like add a Wii/GameCube emulator called dolphin so I can play Super Paper Mario. I know the internet has said that it's too slow IDK. I've installed a version from Github and I would Like to Build it. But after running :

cmake .. -DLINUX_LOCAL_DEV=true -DENABLE_GENERIC=1

I get this error:

fatal: Not a git repository (or any of the parent directories): .git
fatal: Not a git repository (or any of the parent directories): .git
fatal: Not a git repository (or any of the parent directories): .git
fatal: Not a git repository (or any of the parent directories): .git
fatal: Not a git repository (or any of the parent directories): .git
fatal: Not a git repository (or any of the parent directories): .git
-- Detected architecture: armv7l
-- Warning! Building generic build!
-- X11 support enabled
-- Xrandr found
--  Found avcodec: /usr/include/arm-linux-gnueabihf /usr/lib/arm-linux-gnueabihf/libavcodec.so
--  Found avdevice: /usr/include/arm-linux-gnueabihf /usr/lib/arm-linux-gnueabihf/libavdevice.so
--  Found avfilter: /usr/include/arm-linux-gnueabihf /usr/lib/arm-linux-gnueabihf/libavfilter.so
--  Found avformat: /usr/include/arm-linux-gnueabihf /usr/lib/arm-linux-gnueabihf/libavformat.so
--  Found avutil: /usr/include/arm-linux-gnueabihf /usr/lib/arm-linux-gnueabihf/libavutil.so
--  Found swresample: /usr/include/arm-linux-gnueabihf /usr/lib/arm-linux-gnueabihf/libswresample.so
--  Found swscale: /usr/include/arm-linux-gnueabihf /usr/lib/arm-linux-gnueabihf/libswscale.so
-- libav/ffmpeg found, enabling AVI frame dumps
-- libevdev/libudev found, enabling evdev controller backend
-- Using named pipes as controller inputs
-- Watching game memory for changes
-- Enabling analytics collection (subject to end-user opt-in)
-- Could NOT find pugixml (missing:  pugixml_LIBRARIES pugixml_INCLUDE_DIRS) 
-- Using static pugixml from Externals
-- Using static enet from Externals
-- Using static xxhash from Externals
-- Using shared zlib
-- Using static lzo from Externals
-- Using shared libpng
-- Using shared LibUSB
-- Could NOT find SFML (missing:  SFML_NETWORK_LIBRARY SFML_SYSTEM_LIBRARY)
-- Using static SFML 2.1 from Externals
-- Could NOT find MINIUPNPC (missing:  MINIUPNPC_INCLUDE_DIR MINIUPNPC_LIBRARY MINIUPNPC_API_VERSION) 
-- Using static miniupnpc from Externals
-- Could NOT find MBEDTLS (missing:  MBEDTLS_INCLUDE_DIR MBEDTLS_LIBRARY MBEDX509_LIBRARY MBEDCRYPTO_LIBRARY MBEDTLS_VERSION_OK) 
-- Using static mbed TLS from Externals
-- Using shared libcurl
-- Could NOT find HIDAPI (missing:  HIDAPI_LIBRARY HIDAPI_INCLUDE_DIR) 
-- Using static HIDAPI from Externals
-- Could NOT find wxWidgets: Found unsuitable version "3.0.2", but required is at least "3.1.0" (found -L/usr/lib/arm-linux-gnueabihf;-pthread;;;-lwx_gtk2u_core-3.0;-lwx_gtk2u_aui-3.0;-lwx_gtk2u_adv-3.0;-lwx_baseu-3.0)
-- Using static wxWidgets from Externals
CMake Error at Externals/wxWidgets3/CMakeLists.txt:861 (message):
  wxGTK2 needs Xinerama and Xxf86vm


-- Configuring incomplete, errors occurred!
See also "/home/pi/dolphin-master/Build/CMakeFiles/CMakeOutput.log".
See also "/home/pi/dolphin-master/Build/CMakeFiles/CMakeError.log".

enter image description here

  • How did you download dolphin from github? It looks like the error you're getting is expecting you to be an a git repository, created automatically using "git clone github.com/someuser/projecturl.git" – C Malasadas Jun 11 '18 at 23:31
  • I forgot where I got it. But I don't think that is really the issue. I may try re-downloading it from https://github.com/dolphin-emu/dolphin.git – Prolight Jun 12 '18 at 1:07
0

The critical line appears to be:

wxGTK2 needs Xinerama and Xxf86vm

You will need to install Xinerama and Xxf86vm. Particularly, you'll need the development headers for these pacakges. You can use packages.debian.org to find them; just searching with the package names finds the following packages that you'll need to install:

You can try installing those packages with:

sudo apt install libxxf86vm-dev x11proto-xinerama-dev

Then rerunning CMake. This should resolve the error.

  • Nope same error: Could NOT find wxWidgets: Found unsuitable version "3.0.2", but required is at least "3.1.0" (found -L/usr/lib/arm-linux-gnueabihf;-pthread;;;-lwx_gtk2u_core-3.0;-lwx_gtk2u_aui-3.0;-lwx_gtk2u_adv-3.0;-lwx_baseu-3.0) -- Using static wxWidgets from Externals CMake Error at Externals/wxWidgets3/CMakeLists.txt:861 (message): wxGTK2 needs Xinerama and Xxf86vm – Prolight Jun 13 '18 at 6:57

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.