0

I want to use wifi on my rasperry pi. I have a raspberry pi 3 model B. It is running on Raspbian OS. I am accessing it via ssh through putty from my laptop. I am using ethernet cable to do it. Now when I run the command

sudo iwlist wlan0 scan

It replies

wlan0 Interface doesn't support scanning.

And again, when I run the command,

ifconfig

The output is,

    eth0: flags=4163<UP,BROADCAST,RUNNING,MULTICAST>  mtu 1500
        inet 192.168.137.209  netmask 255.255.255.0  broadcast 192.168.137.255
        inet6 fe80::3855:87b5:d951:1bc9  prefixlen 64  scopeid 0x20<link>
        ether b8:27:eb:a9:af:53  txqueuelen 1000  (Ethernet)
        RX packets 1301  bytes 73359 (71.6 KiB)
        RX errors 0  dropped 0  overruns 0  frame 0
        TX packets 167  bytes 23425 (22.8 KiB)
        TX errors 0  dropped 0 overruns 0  carrier 0  collisions 0

    lo: flags=73<UP,LOOPBACK,RUNNING>  mtu 65536
        inet 127.0.0.1  netmask 255.0.0.0
        inet6 ::1  prefixlen 128  scopeid 0x10<host>
        loop  txqueuelen 1000  (Local Loopback)
        RX packets 0  bytes 0 (0.0 B)
        RX errors 0  dropped 0  overruns 0  frame 0
        TX packets 0  bytes 0 (0.0 B)
        TX errors 0  dropped 0 overruns 0  carrier 0  collisions 0

Is my wifi damaged? As far as I know wifi should be built in in rpi 3 model b.

Output of uname -a:

Linux raspberrypi 4.14.48-v7+ #1118 SMP Thu Jun 7 16:40:27 BST 2018 armv7l GNU/Linux

/boot/cmdline.txt:

dwc_otg.lpm_enable=0 console=serial0,115200 console=tty1 root=PARTUUID=4cd51d55d51d55-02 rootfstype=ext4 elevator=deadline fsck.repair=yes rootwait quiet splet splash plymouth.ignore-serial-consoles

/boot/config.txt:

# For more options and information see
# http://rpf.io/configtxt 
# Some settings may impact device functionality. See link above for details

# uncomment if you get no picture on HDMI for a default "safe" mode
#hdmi_safe=1

# uncomment this if your display has a black border of unused pixels visible
# and your display can output without overscan   
#disable_overscan=1

# uncomment the following to adjust overscan. Use positive numbers if console
# goes off screen, and negative if there is too much border
#overscan_left=16
#overscan_right=16
#overscan_top=16
#overscan_bottom=16

# uncomment to force a console size. By default it will be display's size minus
# overscan.
#framebuffer_width=1280
#framebuffer_height=720

# uncomment if hdmi display is not detected and composite is being output
#hdmi_force_hotplug=1

# uncomment to force a specific HDMI mode (this will force VGA)
#hdmi_group=1
#hdmi_mode=1
# uncomment to force a HDMI mode rather than DVI. This can make audio work in
# DMT (computer monitor) modes
#hdmi_drive=2

# uncomment to increase signal to HDMI, if you have interference, blanking, or
# no display
#config_hdmi_boost=4

# uncomment for composite PAL
#sdtv_mode=2

#uncomment to overclock the arm. 700 MHz is the default.
#arm_freq=800

# Uncomment some or all of these to enable the optional hardware interfaces
#dtparam=i2c_arm=on
#dtparam=i2s=on
#dtparam=spi=on
# Uncomment this to enable the lirc-rpi module
#dtoverlay=lirc-rpi

# Additional overlays and parameters are documented /boot/overlays/README

# Enable audio (loads snd_bcm2835)
dtparam=audio=on

EDIT in raspi-config when I enter network options enter image description here

enter image description here

  • Without knowing what you have done it is impossible to say. See How to set up networking/WiFi – Milliways Jun 14 '18 at 5:30
  • DO NOT post questions in Comments to other answers. Have you studied the link in my comment? – Milliways Jun 14 '18 at 10:01
  • Right now, I do not want a static IP. It feels like there is no wifi device in my RPi, because I am not able to scan. So right now, I just want to scan using my wifi and see which connections are available. The questions seems to be to setup a static ip address. – Redwanul Haque Sourave Jun 14 '18 at 10:31
0

Yes, Raspberry Pi 3 Model B have BCM43438 wireless LAN on board.

-Make sure that you are using the latest image of Raspbian OS. If not, download it from here and again try connecting to the Access point. Also if you are beginner try connecting AP(Access Point) from Raspberry pi using GUI method.

-You have mentioned that,

I want to use wifi on my rasperry pi

By this I assume that you want to connect to Access Point(AP)/hotspot.

I would recommend you to keep IP address of wlan0 interface static so whenever you switch on your Raspberry Pi it will automatically connect to that Access point(hotspot).

Start by editing in the dhcpcd.conf file

sudo nano /etc/dhcpcd.conf

You will need to edit this numbers in snippet so that they match your network configuration. Scroll all the way to bottom of file and add this snippet.

interface wlan0 static ip_address=192.168.43.233/24 static routers=192.168.0.1 static domain_name_servers=192.168.0.1

To exit editor, press ctrl+x To save changes press the letter “Y” and press enter and then restart.

  • I want to search for available wifi networks using command line. Currently, the command startx doesnt start any GUI. It prints error messages. – Redwanul Haque Sourave Jun 14 '18 at 7:35
0

Before you can scan (as you did "iwlist wlan0 scan"), you have to bring wlan0 up.

ifconfig wlan0 up
  • Comments are not for extended discussion; this conversation has been moved to chat. – Ghanima Jun 14 '18 at 15:02
0

You STILL haven't specified what OS, but you are obviously running a testing version, probably as a result of running rpi-update and have suspect settings in cmdline.txt

"In normal circumstances there is NEVER a need to run rpi-update as it always gets you to the leading edge firmware and kernel and because that may be a testing version it could leave your RPi unbootable". https://www.raspberrypi.org/forums/viewtopic.php?p=916911#p916911 Even the rpi-update documentation now warns "Even on Raspbian you should only use this with a good reason. This gets you the latest bleeding edge kernel/firmware." sudo apt-get update; sudo apt-get install --reinstall raspberrypi-bootloader raspberrypi-kernel will put it back to the latest supported kernel/bootcode.

Load an unmodified standard OS!

  • I tried at first, I thought it was an update issue. Then I ran rpi-update in hope to resolve it. The problem persisted even before rpi-update I am running on Raspbian OS. The image file says 2018-03-13-raspbian-stretch May be you want to know the version? How to find that? – Redwanul Haque Sourave Jun 14 '18 at 10:24
  • Done that. No results – Redwanul Haque Sourave Jun 14 '18 at 10:52
0

I have flashed a SD Card with Raspbian Stretch Lite 2018-04-18 and booted it in a Raspberry Pi 3B+. I get:

pi@raspberrypi:~$ uname -a
Linux raspberrypi 4.14.34-v7+ #1110 SMP Mon Apr 16 15:18:51 BST 2018 armv7l GNU/Linux

Your kernel is:

Linux raspberrypi 4.14.48-v7+ #1118 SMP Thu Jun 7 16:40:27 BST 2018 armv7l GNU/Linux

This is obviously the wrong kernel you are using. Please use a fresh flashed SD Card with the image I have done. Then everything works as expected (have tested it). You will see wlan0 with ifconfig and you can scan the wifi network with sudo iwlist wlan0 scan. If this does not work on your raspi I only see two possibilities:

  1. Your Raspberry Pi is broken
  2. You do not use a Raspberry Pi 3 model B.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.