0

I've had my RPi for a while now, and thought I'd try and set it up with SSH. I've followed loads of tutorials on how to set it up correctly, but when I try and open the ip address in putty, I get a "Connection Timed out". when I ping my RPi from my PC, it receives the packages but it also says "receiving host not available".

can anyone help me, please?

  • Are you running raspbian or another distribution? – aleixrocks Jul 19 '13 at 10:32
  • 1
    You can enable SSH via the GUI provided by sudo raspi-config – Gerben Jul 19 '13 at 12:44
  • how do you know rpi IP address? it's dynamically acquired through DHCP - which means you can usually get it from router or scan your network with tool like nmap (nmap -sP 192.168.1.0/24) – RooTer Jul 20 '13 at 13:04
1

I've had my RPI for a while...

Originally the RPi's didn't have ssh enabled by default. Plug your RPi into your TV or a monitor and a keyboard and type sudo raspi-config. Then you can enable openssh through the menu.

If there's nothing of importance on the card you could just reflash your distro and that should solve your issue too.

0

If you are on a different network to your PC, it may be that your Pi's request for a port on your PC (and vice versa) is being blocked by the firewall.

If this is the case, a naive explanation goes: you will likely find yourself looking into reverse tunnelling with SSH: Dialling 'home' - your PC's static IP - and then having your PC loop that back on localhost so you can talk to the Pi.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.