0

I have opencv installed on RPi. Now I need to install OpenNi2 and I have this error: "error: array subscript is below array bound"

I use: PLATFORM=Arm make

gcc -v 6.3.0

How to solve the problem with above error?

In OpenNI2 README we have Cross-Compiling for ARM on Linux: The following environment variables should be defined: - ARM_CXX= - ARM_STAGING= Then, run: $ PLATFORM=Arm make

But I do not know hot to setup

ARM_CXX=

ARM_STAGING=

0

You could use "sudo apt install libopenni2-0 libopenni2-dev"

This installs the "2.2.0.33+dfsg-7+rpi1 armhf" version of the library.

There are also "openni2-doc" and "openni2-utils".

These seem to be the latest available binaries.

  • Thank you for your answer. The installation has passed successfully. Are sample projects also installed with the library? If so, in what catalog can I find examples? – Rariusz Jun 18 '18 at 8:02
  • I'm sorry, but I don't know. They might be in the openni2-utils, or you might have to go to the structure.io site and see if they have what you need. I would build the samples on the Raspberry Pi so you don't have to worry about cross-compilation. – NomadMaker Jun 18 '18 at 10:30
  • I run without compiling NIViewer example so everything works. I have stream from a camera but when I want to compile SimpleViewer I have the following error "include<OpenNI.h> not found". I will have to work a bit more on this – Rariusz Jun 18 '18 at 12:08

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.