0

[EDIT]: Here is how to do it:

Find the download link and wget it. If your downloading from Oracle they make you accept the licence agreement, and then give you the link. If you get a certificate error, add the no-check-certificate option to wget.

If you want the Oracle JDK8 for ARM, issue this statement:

wget http://www.java.net/download/jdk8/archive/b99/binaries/jdk-8-ea-b99-linux-arm-vfp-hflt-17_jul_2013.tar.gz --no-check-certificate

[/EDIT]

I am attempting to download the JDK8 for Linux ARM (218.45MB file) from https://jdk8.java.net/download.html .

If I accept Oracle's agreement and get the link, I try this in WGET:

wget http://www.java.net/download/jdk8/archive/b99/binaries/jdk-8-ea-b99-linux-arm-vfp-hflt-17_jul_2013.tar.gz

and receive the following error:

Connecting to www.java.net (www.java.net)|209.189.227.38|:443... connected.
ERROR: The certificate of `www.java.net' is not trusted.
ERROR: The certificate of `www.java.net' hasn't got a known issuer.

The first time I tried to download it, it actually got about 99% of the way through before Midori crashed. The MD5 didn't match.

Now every time I try it appears to be getting worse, now its crashing at less than a third of the way there. I've tried about 10 times.

Even when I initially got my RPi and had no programs running, Midori seemed to crash a lot.

How can I get around this?

With Midori open, my free -h says 16M free in memory, 31M free in buffers/cache. With Midori closed, my free -h says 7M in memory, 114M in buffers/cache.

  • Try adding --no-check-certificate to the wget command; My pi can download it. – Jacobm001 Jul 19 '13 at 22:52
  • @Jacobm001 Sweet it is downloading I'll give you the answer as soon as it completes. Thank you for this answer and the MD5! – Matthew Moisen Jul 19 '13 at 22:56
  • No problem, glad they helped! – Jacobm001 Jul 19 '13 at 22:57
1

I have no idea why Midori has as much trouble as it does, but I managed to grab the url for you:

http://www.java.net/download/jdk8/archive/b99/binaries/jdk-8-ea-b99-linux-arm-vfp-hflt-17_jul_2013.tar.gz
  • Hey @Jacobm001, I tried that route earlier with wget and I receive the error listed in my edit above. Do you know a way around that? Thanks – Matthew Moisen Jul 19 '13 at 22:51
  • Try adding: --no-check-certificate – Jacobm001 Jul 19 '13 at 22:54

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.