0

I am SSHed into the Pi using PuTTY on a Windows computer. Everything works fine as expected but if I don't do anything on the Pi for roughly 5-10 minutes and then come back to it there is some weird delay (of about 5-10 seconds) before the SSH window becomes responsive again. This means for those 5-10 seconds, it does not take any inputs from my keyboard or selects the previous command if I push the up arrow on my keyboard.

I don't think this issue is an SSH problem necessarily. The same symptoms above seem to happen when I send a POST request to a webserver running on the Pi.

I have tried:

  • Disabling power management on the network card.
  • Disabling Bluetooth (Don't need it anyway, disabled to save power.)
  • And everything that came up online regarding possible similar issues (although nothing worked)
  • Seeing if it is overheating. Its not.

The Pi is running Stretch Raspbian (Linux raspberrypi 4.14.34+ #1110)

I'll attach the log file (var/log/messages) but I can't seem to find anything obvious in it: https://pastebin.com/YfUV9aF0

  • may be a screensaver or may be sleep mode – jsotola Jun 23 '18 at 22:15
  • @jsotola I forgot to mention it is entirely headless. Care to elaborate as to how I could fix the issues you mentioned? – Erozionn Jun 24 '18 at 23:04
  • it was just an idea that popped into my head ... i do not know how to check if either a screen saver or sleep/power-save mode may be active on your RPi – jsotola Jun 24 '18 at 23:28
  • Maybe it isn't the raspi. Instead it could be the windows computer with putty doing this delay. – Ingo Jun 26 '18 at 8:16
  • As mentioned before, it also happens when I make an HTTP request to the pi. I think that rules out it being an issue with putty/windows/ssh. – Erozionn Aug 27 '18 at 19:29
0

We use hundreds of Pis in a production environment (as a replacement for thin clients). We've noticed a similar problem. It happens on either ethernet or wireless. After about 5-10 minutes of inactivity a new request to the server can result in a delay anywhere from 30 seconds to 2 minutes.

This only seems to happen on the 4.14 kernel, does not happen on 4.9. Because of this we can't use any of the new 3B+ Pis yet.

0

My Rpi0 runs on a Kali Linux with kernel v4.4.50+ and I have never experienced this issue.

All I can suggest is to SSH into you Rpi0/W, run the top utility, and let it sit for 5-10 minutes. Observe the top activity when trying to access your Rpi0/W to see what happens that causes the delay.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.