0

I have changed the wpa_supplicant.conf file on my Raspberry Pi 3 (running Raspbian Lite) to the proper SSID and password of our WPA2 WiFi, and it shows the proper SSID when running iwconfig. However:

  • When I run nmcli general status, it says the Raspberry Pi is disconnected.
  • The Raspberry Pi is not detected on our router's configuration page.
  • The /etc/network/interfaces file only contains comments and a reference to an empty source directory (interfaces.d), unlike how I've typically seen the file online.

The /etc/wpa_supplicant/wpa_supplicant.conf file currently looks like this (with the SSID and password replaced by the proper information):

ctrl_interface=DIR=/var/run/wpa_supplicant GROUP=netdev
update_config=1
country=US

network={
    ssid="wifi_name"
    psk="wifi_password"
}

How could I establish a functioning connection?

1

What OS are you running?

nmcli is a command-line tool for controlling NetworkManager which is NOT installed or used by Raspbian. NetworkManager does not use wpa_supplicant.conf

See How to set up networking/WiFi for setting up networking on Raspbian.

  • I'm running Raspbian Lite and have installed network manager, but from what you're saying, it sounds as if nmcli may produce unreliable results. My Raspberry Pi was successful when I pinged to various sites and my local gateway, so why do you think it's not shown as an "attached device" to my router? I have already followed the steps in your link. – Matthew Taylor Jun 24 '18 at 13:09
  • You have 2 incompatible network managers installed NetworkManager and dhcpcd (the standard). The link describes configuring dhcpcd on Raspbian; if you want to use NetworkManager you will have to configure it, but this is normally done by the GUI. Don't expect any help for NetworkManager on this site - try a Ubuntu forum. – Milliways Jun 25 '18 at 0:29
  • I ended up switching the OS from Raspbian Lite to the full version of Raspbian, and that did the trick. Thanks for taking the time to help! – Matthew Taylor Jun 25 '18 at 0:50

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.