2

I have a Raspberry Pi 3 model B and am using Retropie.

I have it connected to to portable display, but when I plug in headphones, I get no audio.

Any help will be much appreciated, and I will answer questions.

2

If you connect the hdmi first, it will use the hdmi as the audio output.

Try connecting the audio jack first.

0

The Raspberry Pi organisation has some detailed pages to help with Audio problems:
https://www.raspberrypi.org/documentation/configuration/audio-config.md
https://www.raspberrypi.org/documentation/usage/audio/

In summary: First download the example MP3 file using the following command in terminal:

wget http://rpf.io/lamp3 -O example.mp3 --no-check-certificate

To play an MP3 file, navigate to the location of the .mp3 file in the terminal using cd and then type the following command:

omxplayer example.mp3`

This will play the audio file example.mp3 through either your monitor's built-in speakers or your headphones, connected via the headphone jack.

If you cannot hear anything, make sure your headphones or speakers are connected correctly. Note that omxplayer doesn't use ALSA and so ignores the audio configuration set by raspi-config or amixer.

If your HDMI monitor or TV has built-in speakers, the audio can be played over the HDMI cable

Try connecting your Pi to a HDMI monitor or TV that can also output sound. See if this works.

If omxplayer's auto-detection of the correct audio output device fails, you can force output over HDMI with:

omxplayer -o hdmi example.mp3

Alternatively, you can force output over the headphone jack with:

omxplayer -o local example.mp3

You can even force output over both the headphone jack and HDMI with:

omxplayer -o both example.mp3

Right-clicking the volume icon on the desktop taskbar brings up the audio output selector; this allows you to select between the internal audio outputs. It also allows you to select any external audio devices, such as USB sound cards and Bluetooth audio devices. A green tick is shown against the currently selected audio output device — simply left-click the desired output in the pop-up menu to change this. The volume control and mute operate on the currently selected device.

If that doesn't work...

The following command, entered in the command line, will switch the audio output to HDMI:

amixer cset numid=3 2

Here the output is being set to 2, which is HDMI. Setting the output to 1 switches to analogue (headphone jack). The default setting is 0 which is automatic.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.