1

I've configured an access point on my Pi 3, largely using this tutorial:

https://blog.thewalr.us/2017/09/26/raspberry-pi-zero-w-simultaneous-ap-and-managed-mode-wifi/

So the Pi connects over wlan0 to my router, and devices connect to the Pi on ap0. IPv4 forwarding is enabled so ap0 devices have transparent access through to everything offered by the router's DNS.

This works great... with some of my devices. My 2011 Compaq laptop, running Ubuntu 18.04, connects to the access point, and everything just works with the same performance as if it were connected straight to the router. This device has an Atheros 9485GN Wi-Fi adapter.

I can also connect to the network successfully from my Nokia Lumia 930 on Windows 10 Mobile.

However, some other devices don't seem to work at all. So far, I've found these to be my Surface Pro (2017, Marvell AVASTAR AC adapter), and my Nokia 6. In both instances, they connect successfully to the Pi access point, have an IP and show as connected. But there is no connectivity whatsoever - everything times out, even though the connection is established and stable.

Occasionally connectivity is achieved for a few seconds or so, and it becomes possible to ping, but then it drops again (but the connection itself never drops, it's just traffic seems to get stuck).

When multiple devices are connected, the same thing occurs. According to every indication inside Windows, the Surface has a working connection, but nothing actually gets through. The Compaq, connected at the same time, loads everything without any issues.

What could be causing this?

It's taken me long enough to get the Pi's Wi-Fi AP working at the same time as client mode. I'm not experienced with Linux networking, so I'm at a bit of a loss as to what's going on, and why only some devices are having problems. Initially I thought it was just the Surface, but it's now clear it's not.

My initial suspicion is something's wrong with the AP broadcast itself - channel or frequency band. I have observed that after starting the Pi always uses channel 1, even though channel 11 is specified in hostapd.conf. I'm not quite sure yet what channel I should be using...

The aim for the project is to get the Pi working as a Wi-Fi repeater into the garden, so I can work outside... with the Surface. So right now, the only device I actually need to have working, isn't.

Tl;dr: Some devices connect fine. Some devices connect to the AP, but everything times out.

  • Please clarify title: When I read it I asked myself, what type of access point. Is it a door lock, is it maybe to guard access to a network, or something else. Please update title. – ctrl-alt-delor Jun 29 '18 at 13:28
  • Given that the Pi is hosting two wifi networks, is wifi interference an issue? I.e., does using eth0 for your router connection improve anything? – OyaMist Jun 29 '18 at 13:35
  • 1
    @OyaMistAeroponics Not something I have tried, but I think "no", as everything is fine on the devices that can connect. Since writing this post, I've tried switching everything to channel 11 (no impact), and disabling everything on the Surface that could interfere... Hyper-V virtual network adapters, Bluetooth, Wi-Fi power saving modes. No impact. Sometimes, the Surface works fine for a few minutes...then it drops, but still displays full signal and healthy connection. But no packets are received. At the same time the Ubuntu Compaq can still be browsing the web with no problems. It's strange. – Ilmiont Jun 29 '18 at 13:38
  • Have you tried asking these questions of the author of the tutorial you followed? I see that a bash script to "auto-configure" iaw the tutorial is offered... have you tried the latest version of that? – Seamus Jun 30 '18 at 12:22
  • @Seamus yes actually, I have left comments on the post, and the author has been very responsive. But I think the issues lie outside of the scope of the tutorial - it focuses on enabling simultaneous managed/AP, which is working fine in my setup (the AP itself never drops, just the Surface and Nokia 6 have no traffic throughput). The devices which it does work with, work without any trouble. I'm still looking into it... Initially I thought it was just the Surface but the phone is definitely having problems too, but I'm reluctant to make any conclusions yet about where the problem lies. – Ilmiont Jun 30 '18 at 14:27

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Browse other questions tagged or ask your own question.