1

I'm using the June 27, 2018 build of Raspbian Stretch that I downloaded (via torrent) from https://www.raspberrypi.org/downloads/raspbian/

I am using a Class 10 Samsung (not a knock-off) 32GB microSD card that was new-in-box before I imaged it.

I'm powering from a 5.2v 2.0amp USB power supply that I borrowed from my room mate's Pi Zero (he's been using it for years). The cord connecting my Pi Zero to the adaptor is about three inches long (I'm aware that long cable runs can cause issues).

HDMI output is to a mini-HDMI-to-HDMI adapter then to a premium HDMI cable (gold connectors, heavy shielding) to the monitor.

The keyboard and WiFi dongle are connected via a powered USB hub (Unitek).

First boot went fine. I set my localization (US, Central Time, US Keyboard), renamed my Pi (so tempted to call it Apple - but didn't), and set a password.

The device tried to update the OS but as my WiFi dongle didn't get picked up, that didn't work.

I hadn't expected it to pick up the WiFi dongle, but as it was one marketed to work with the Pi Zero, I had at least a small hope that it might.

As soon as I was done with the device setup and localization, I rebooted my Pi via the system menu.

It came up just fine.

At that point I started looking at getting my WiFi dongle to work and found a website that gave some very specific instructions:

sudo nano /etc/network/interfaces

Then make it look like this:

# Include files from /etc/network/interfaces.d:
source-directory /etc/network/interfaces.d

auto lo
iface lo inet loopback

iface eth0 inet dhcp

allow-hotplug wlan0
auto wlan0
iface wlan0 inet manual
    wpa-ssid "your-network-name"
    wpa-psk "your-network-password"
    iface default inet dhcp
    # wpa-conf /etc/wpa_supplicant/wpa_supplicant.conf

# allow-hotplug wlan1
# iface wlan1 inet manual
#     wpa-conf /etc/wpa_supplicant/wpa_supplicant.conf

Saved the file and exited, then shut down via this:

sudo shutdown

I was under the impression that all I needed to do to boot this thing was unplug it and plug it back in. When I do that, all that I get is one flash of the "I can read the SD card LED and then nothing - no HDMI signal, no flashing lights, no naked dancing girls, nothing.

Is there something I missed here?

I've pulled all the inputs and the microSD card and attached my Pi via USB port (not the power port) to a Windows 10 computer and it registers as "BCM2708 Boot" just fine, so the device itself isn't dead.

I tried removing the USB Hub and connecting the Keyboard dongle (but not the WiFi dongle) via direct connection to the OTG USB to USB A adapter I previously used to connect the Hub to the Pi with.

No joy and no difference at all in response. One flash of the LED and then crickets.

It's not booting up, it's not so dead that Windows doesn't think it's a valid USB device, and it's not telling me WHY it's not booting up.

Please bear in mind that as technical as all of the information I've provided here LOOKS, this is all monkey-see-monkey-do for me. If you have instructions, please make them idiotically specific and detailed.

0

Try booting it up with everything connected again. This is a good page for troubleshooting boot problems. When you reboot, watch the screen and see if you get anything on boot up.

Are you sure that it's just one flash instead of two flashes? Two flashes indicates that it can't read the SD card, but one flash indicates that you have a Pi from Micron. Just because another computer can read an SD card doesn't mean a Raspberry Pi can do it. The readers on Windows machines are more "liberal" in reading them than Linux machines. Also the Windows machine will only read the boot partition which will not detect a problem if only the main partition has been corrupted.

I tend to use cheap SD cards and have never had a problem.

  • Very definitely one flash only. I've recreated the problem several times and watched very closely as I did. I am unclear what "you have a Pi from Micron" means. I didn't put the SD card into a reader on a my Windows PC. I hooked up the Pi itself with all externals and the SD card itself removed. I found a site that recommended that as a first step if you could not boot your Pi as it's supposed to indicate if the Pi is dead or if the problem is somewhere else. – MLT Jul 3 '18 at 7:57
  • I'll try reimaging, but I don't have any idea why it failed in the first place and short of finding a set of instructions for setting up a WiFi dongle and connecting it to my Pi Zero (non-W) - and that page linked by Milliways is useless to me - I've no idea how I'm not going to end up right back here. I got zero response from the screen and exactly one flash, I've repeated this enough times to be sure about that. – MLT Jul 3 '18 at 8:11
  • If I understand the page you sent me to, this shouldn't be my problem (the Micron Pi) as the image I downloaded is from way, way, way after 2013, but I'm reflashing now. I'll give it a shot. Maybe something went awry in the initial flash that didn't get caught immediately. – MLT Jul 3 '18 at 8:14
  • The signals used to indicate errors with the ACT led repeat. The flashes are separated by a brief pause, the set separated by a longer one. E.g., "two flashes" would be -- -- --. In that context, "one flash" would be a steady pulse: - - - -. Pretty sure that's not what the OP meant by "one flash". – goldilocks Jul 3 '18 at 10:44
  • The Windows machine reporting the SD card as "BCM2708 Boot" is just reading a label on the first partition, which doesn't mean much. It should also be able to mount that first small vfat partition. Unless you install third party software, it won't be able to recognize the second (i.e., NomadMaker has it backwards here WRT "liberalness"). – goldilocks Jul 3 '18 at 10:53
0

Hmm... as far as I read you have taken all things I imagine to minimize errors. In such situations I try to strip down the installation to the essentials and then build it up step by step. I do not have a Pi Zero, only Pis 3B(+) so this may not exactly match your needs.

First I use a USB serial to TTL converter adapter to connect to the debug serial console on pin numbers 6 (GND), 8 (GPIO14, TXD), 10 (GPIO15, RXD). I have bought it for about 10 €. Then connect it to my laptop and use a classic serial terminal program. On linux it is screen /dev/ttyUSB0 115200, don't know what to use on windows. Flash Raspbian Stretch Lite 2018-06-27, that is without any graphics stuff. Mount the flashed SD Card to your Laptop so you can add this line to config.txt:

enable_uart=1

Put the SD Card into the raspi where only the serial adapter and the power supply is connected. It boots endless times (at least on my raspis) and you can see the boot messages on the serial terminal.

Now I would attach the wifi USB dongle to the raspi and look if it boots more than three times. Then configure wpa_supplicant to use wifi, reboot more than three times. You can build up your environment step by step and verify where it fails.

It may also help to use the debug-shell service. Look at:

rpi ~$ zcat /usr/share/doc/systemd/README.Debian.gz | less

There is a section called "Debugging boot/shutdown problems".

  • I'm sorry, but I cannot get far enough into the boot process to do any of that. I get zero response from the monitor and only a single LED flash on the Pi. This after the initial boot, then the restart after making some configuration changes and a sudo shutdown comand. It's be dead since, but I still get a good read by a windows PC when I remove everything and hook it up via USB. The power supply was itself feeding from a UPS, so I doubt a power surge. I'm at a loss as to what happened here. – MLT Jul 8 '18 at 9:11

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.