1

So I'm setting a new fedora install on my raspberrypi (version: newest pidora).

Everything works, except vnc, any connection attempts are rejected.

So, as I'd like to make it working now and worry about security later, I clear iptables with

iptables -F
iptables -X
iptables -t nat -F
iptables -t nat -X
iptables -t mangle -F
iptables -t mangle -X
iptables -P INPUT ACCEPT
iptables -P OUTPUT ACCEPT
iptables -P FORWARD ACCEPT

Hacky, I know, but it makes VNC working.

Then, no matter whether I do

/sbin/service iptables save

or

iptables-save > /etc/sysconfig/iptables

previous, non-permissive rules are restored, and thus, I can't get VNC to connect.

So, what gives? What's the problem?

For further reference, here are both iptables:

The 'unclean' one, the one that gets restored, and one which I don't want:

http://pastebin.com/UA3FKh9v

and the 'clean' one, the one that appears in iptables config file after iptables save, and the one that gets deleted after each reboot:

http://pastebin.com/Mj79YQ7g

migrated from serverfault.com Jul 23 '13 at 9:06

This question came from our site for system and network administrators.

2

The newer Fedora versions (after 18) use firewalld as a default solution instead of iptables. So all the configuration files are in /etc/firewalld

You can read extensively about firewalld configuration options here .

Since you effectively want to stop the firewall service just do systemctl stop firewalld.service or to make it permanent systemctl disable firewalld.service

  • Ew. Did not know that. Seems like a bad idea. – dmourati Jul 23 '13 at 9:02
  • @dmourati : If you mean disabling firewalld is a bad idea, not necessarily. It isn't intended to be more secure than iptables, it is just more "feature rich". – goldilocks Jul 23 '13 at 9:38
  • @dmourati well that is what he was describing that he was doing if you check the actual pastbin files he posted. and yes depending on your particulars running without a firewall can be problematic – thanosk Jul 23 '13 at 9:44

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy