0

I am trying to connect my Pi 3 that is located at my home from my office network but Windows' RDP client giving error immediately.

I am using DDNS service and I can connect my home desktop PC through RDP from my office without a problem. I am able to connect my Pi from local too and also I am using port 4489 for my Pi's xrdp and 3389 for my home PC's RDP. In addition I can SSH to the Pi from my office too.

Any idea what's causing this?

  • So it's either a breakdown in the network path from your office network to your pi, or it's a problem with the RDP service running on the pi. But there's not enough immediate information to answer your question. Here's a series of points to start looking over and checking. 1. What is the error it's giving you? (You should list that here.) 2. Are you using a router to handle incoming traffic from your ddns address? 3. If so, are you properly forwarding the RDP port (4489) for your Pi in the router's settings? Since you can SSH to your Pi, if you're also forwarding the correct port I'm going to – user79543 Jul 3 '18 at 18:55
  • Like Tegan I also guess it's a problem with port forwarding in your home router. Can you connect to the raspi if you set its port for testing to 3389? – Ingo Jul 3 '18 at 21:32
  • could also be server authentication settings in your RDP client – Jaromanda X Jul 3 '18 at 23:23
0

I manage to connect my Pi.

When i changed the listening port of xrdp to 4489, i just changed one line at the top of xrdp.ini file. Then i figured out there were different rdp client configs at the bottom of xrdp.ini file that i wasn't change at all. So i just changed the ones that equals to 3389 to 4489 and it start working.

But still wondering if i was able to connect from local network why i couldn't do it from public one.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.