1

I'm using the latest CentOS release on my RPi and I'd like to start playing with docker. I tried following the official instructions here. I installed the dependencies and enabled the repo, but when I tried to run sudo yum install docker-ce, I got the following error:

https://download.docker.com/linux/centos/7/armhfp/stable/repodata/repomd.xml: [Errno 14] HTTPS Error 404 - Not Found

Does this mean there is no docker build for CentOS on the RPi? If not, what's the easiest way to make this happen?

3

If You need install Docker at RPI3 + CentOS, run next command

sudo yum install docker -y

add Docker to startup - sudo systemctl enable docker.service Run Docker - systemctl start docker

| improve this answer | |
1

Not many OS distros package docker for the CPU architecture of the RaspberryPi - armhf. Your error indicates that CentOS doesn't have a docker package for you.

You will need to install it like this:

curl -sSL https://get.docker.com | sh

This is further explained in this raspberrypi.org article: https://www.raspberrypi.org/blog/docker-comes-to-raspberry-pi/

| improve this answer | |
0

The problem is docker for CentOS uses armv7l as identifier for the 32 bits architecture and the raspberry tries to install the armhfp architecture because that is the value that outputs $basearch variable. That's why you get a 404 when you try to install docker after adding your docker repo.

In order to solve it you need

  • Add the docker repository.
  • Go inside of the /etc/yum.repos.d/docker-ce.repo and update the $basearch with armv7l and comment the reference to the docker-ce-stablebecause at least today(2020-06-11) there is no a stable version.
  • Then you need to install docker with: yum install docker.armv7hl
| improve this answer | |

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.