1

I can connect to Wi-Fi when I use RPi 3B but when I boot the system with 3B+ it doesn't connect to Wi-Fi automatically and when I click on the top right to connect it to Wi-Fi, I see the error:

no wireless interfaces found.

We tried

sudo rpi-update 
sudo apt-get update
sudo apt-get upgrade

and some other common solutions on the internet but none of them solved the problem. I can connect to internet via Ethernet but I need to connect to Wi-Fi. I also tried to set the country code but it did not work.

Are there any other solutions we can try?

  • @joan Sorry about the confusion. I edited the question, hopefully it is more clear now. – canberkbaykal Jul 6 '18 at 7:12
  • 2
    > "In normal circumstances there is NEVER a need to run rpi-update as it always gets you to the leading edge firmware and kernel and because that may be a testing version it could leave your RPi unbootable". raspberrypi.org/forums/viewtopic.php?p=916911#p916911 Even the rpi-update documentation now warns "Even on Raspbian you should only use this with a good reason. This gets you the latest bleeding edge kernel/firmware." – Milliways Jul 6 '18 at 8:06
  • sudo apt-get update; sudo apt-get install --reinstall raspberrypi-bootloader raspberrypi-kernel will put it back to the latest supported kernel/bootcode. THEN you can start solving your problem. – Milliways Jul 6 '18 at 8:06
  • See How to set up networking/WiFi which describes the options for setup and common shortcomings. – Milliways Jul 6 '18 at 8:09
  • @Milliways I ran rpi-update because the system did not boot on RPi 3B+. After the update I was able to boot the system so I don't know if removing the updates will solve my problem – canberkbaykal Jul 6 '18 at 8:36
0

I seems you take the SD Card from the RPi 3B and put it into the RPi 3B+. This cannot work because the RPI 3B+ has new hardware, particular a new wifi chip. This needs new device drivers so it is recommended to use the latest Raspbian images. If you want to update the SD Card from the RPi 3B you can do it as described in Why am I getting a rainbow screen and flashing red PWR LED with a new Raspberry Pi 3B+?

0

The problem was I was running Raspbian Jessie and it was not supported by Pi3B+. Installing the latest version of Raspbian Stretch solved my issue.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.