0

In my setup I have an OpenVSwitch on a Raspberry Pi.

Using the below tutorial I set up an access point on the Raspberry Pi (This is done by creating a bridge between eth0 and wlan0) I could successfully connect devices to the internet by connecting to the Raspberry Pi.

https://www.raspberrypi.org/documentation/configuration/wireless/access-point.md

Next I needed to connect the OpenVSwitch to the OpenDaylight controller. This is done by creating the an OpenVSwitch bridge between the controller and eth0. But the problem is that eth0 appears busy due to the Raspberry Pi access point.

I tried doing it the other way round i.e. by adding the the wlan0 to the OpenVSwitch bridge. But doing it that way, devices are not able to connect to the raspberry pi and I am not sure what the problem is.

1

Real OSI layer 2 bridging an access point to an ethernet port works but bridging a wifi client connection to an ethernet port does not using the kernel build in linux bridge. Bridging wifi is specified with WDS (Wireless Distribution System) and needs an additional address field enabled in the ip header. This must be supported by the wifi device by enabling 4addr. Raspberry Pi does not support it. For further information look at Raspberry Pi WiFi to Ethernet Bridge for a server?.

I don't know if OpenVSwitch can bridge wifi anyway. But because it is a hardware supported feature it is very likely that it can't.

Please tell me if you can make a real OSI layer 2 bridge (not a faked routing with NAT) with wifi using OpenVSwitch on a raspi by giving me a comment under this answer. I'm very interested in this.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.