0

I have:

  • Connected rasspbery pi zero with HAT GSM/GPRS/GNSS/Bluetooth by gold-pins.
  • List item
  • Switched UART to B-position Raspbian version: 9 (stretch)

When I used pwdrkey i have only PWR and STA leds lighting constantly in red and NET flashing 1 per 2/3 seconds.

I switched in raspi-config:

Interfacing -> Serial -> No (shell) -> Yes (hardware)

And when i come into minicom by: sudo minicom -D /dev/ttyAMA0 I cannot do anything, nothing happened except:

Welcome to minicom 2.7

OPTIONS: I18n Compiled on Apr 22 2017, 09:14:19 Port /dev/ttyAMA0, 17:27:44

Press CTRL-A Z for help on special keys

And on bottom bar:

CTRL-A Z for help | 9600 8N1 | NOR | Minicom 2.7 | UT102 || Offline | ttyAMA0

And now I can only disconnect power cable, because any keybord combination do nothing.

Any help?

0
  • Do you try to put your yellow pins on the "B" ? they are on your GPS card, if you have a serial connection, you must make this configuration. Else, you have to make them in the position "A"... look on your GPS card, you will not be able to miss them x'D

  • Do you try to do this :

    1. sudo minicom
    2. ctrl+A
    3. o
    4. serial port configuration
    5. A
    6. /dev/ttyS0
    7. enter
    8. E
    9. make 9600 or 115200
    10. save and reboot
  • Try:

    sudo raspi-config-- Interfacing options--Serial--No--Yes--Save 
    

    and reboot.

  • Try to : go on your menu--preferences--raspberry pi configuration--interfaces--make Serial enable--reboot.

  • Don't run your program in the same time of minicom

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.