1

Using a RPI 3B running Debian Jessie, I've been trying to get a simple stream of the "flatmax" audioinjector's onboard mic over RTP to a VLC player. I've tried many different commands such as:

ffmpeg -re -i hw:0,0 -f sap sap://224.0.0.255?same_port=1

which gives me a

hw:0,0: Protocol not found 

error (as do many commands I've tried).

or:

ffmpeg-f alsa -i plughw -f rtp rtp://destinationHost:port

and

ffmpeg -ac 1 -f alsa -i hw:1,0 -acodec mp2 -ab 32k -ac 1 -re -f rtp rtp://224.168.2.105:1234 

which give me

Unknown input format 'alsa'

errors.

I am not sure why I keep getting these errors, as it seems I have the alsa drivers setup correctly, with the audioinjector being my default audio device. Is something not installed right, and what would it be?

I have however, managed to get an RTP stream up and running with a workaround:

arecord -f cd -D plughw:1,0 | ffmpeg -re -i - -acodec mp2 -ab 32k -ac 1 -f rtp rtp://224.1.2.3:7000 

This creates a working RTP stream that I can detect and open on a separate device on the network, but the kicker is that I cannot seem to get any audio input into it.

So, it seems that something needs to be fixed on the audio input end of this. I'm not terribly experienced with this stuff, so feel free to throw ideas!

  • 1
    Bump! Still not working. – Josh HP Jul 10 '18 at 14:53

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Browse other questions tagged or ask your own question.